1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic (64 bit) cant open with 003 Rack

Discussion in 'Logic 9' started by Machino, Apr 26, 2010.

  1. Machino

    Machino New Member

    Hi everybody:)...

    First time poster with a bit of a problem

    I have:

    Logic 9.1.1
    Mac OS 10.6.2
    27" imac core i7 8GB ram
    Digi 003Rack
    Protool 8.0.3 cs2

    The problem is, when i try to open logic it just crashes before i even get to the opening screen with the following message: "Logic Pro unexpectadly quit under ussage of the core audio accessory" (translated from danish)

    Any advice would be highly appreciated.

    Best Regards

  3. Markdvc

    Markdvc Administrator Staff Member

    Hi there, and welcome to the LUG.

    Does Logic open running in 32 bit? If so, what happens if you switch off the 003 as audio device in logic's audio preferences, revert to internal audio and then try starting Logic in 64 bit?

    Perhaps the problem is the 003 Core Audio Drivers? Are they 64 bit? I am not at all familier with Digi but understand that PT 8.0.3 has 64 bit core audio drivers. I have no idea how stable and reliable that is.

    It could make sense for you to contact digidesign about this.

    FWIW, Logic 9.1.1 runs fine in 64 bit here using Metric Halo hardware.

    kind regards

  4. Machino

    Machino New Member

    Hi Mark, and thanks for your reply.

    Logic runs just fine in 64 bit mode, if the 003 is switched off. It also works with the 003 in 32 bit mode. Its a bit annoying that i cant make it work - especially since the 8,0,3 update should make the digi core driver 64 bit. Im kind of lost here:)
  5. bobdemaa

    bobdemaa Senior member

    It sounds like something didn't get trashed / installed when you ran the 8.0.3. update... I'm not on a system with core audio drivers installed, but you might want to try finding the Digidesign Core audio extensions, trashing them manually, and then re-install the 8.0.3. update. it's probably what I would do.

    But be really careful if you don't have experience with doing that. best to call DIGI first.
  6. Lincoln M

    Lincoln M Member

    Check and see that the sample rate is consistent.

    Open the digi core audio manager and see what sample rate it's set to.

    Turn off the 003r.

    Open logic an set the sample rate to match the digi core audio manager.

    Close logic - turn on 003r - open logic - select 003r as audio interface.

    Hope this helps...
  7. Machino

    Machino New Member

    Wow, that actually worked... They were allready both set at 44.1 Khz, so i have no idea what it did. Was it just the "turning on and off in sequence thing" that helped?

    Biiig thanks
  8. Lincoln M

    Lincoln M Member

    Sometimes the digi core audio driver can cause some problems and it's always nice when just a power cycle handles it!

    Glad you got it going.

Share This Page