1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 7 & earlier Logic 7.2.3 compatible with Snow Leopard?

Discussion in 'Logic 7 and older Versions' started by mDay, Feb 6, 2010.

  1. mDay

    mDay Member

    does anyone know? thanks in advance!
  3. Markdvc

    Markdvc Administrator Staff Member

    Logic Pro 7.2.3 is running on two Intel Macs in 10.6.2 here. I am mostly using it whenever I need to access some very old, pre Logic 5 files, so am not putting it through the same paces as logic 9, but it does seem to be OK in Snow Leopard.

    kind regards

  4. mDay

    mDay Member

    sweet...thanks Mark!

Share This Page