Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9 and Waves Complete Bundle 7

Discussion in 'Logic 9' started by btoth17, Apr 15, 2011.

  1. btoth17

    btoth17 New Member

    I am trying to import the waves bundle 7 to Logic 9, but after installing they wont show up as plugins in Logic. Everything looks to be where it belongs, the only issue I can see is that the waves bundle isn't working with the updated logic 9 and mac osx. I am running Logic 9.1.3 and mac osx 10.6.6.

    anyone have any ideas?

  3. Markdvc

    Markdvc Administrator Staff Member

    I'm not sure what you mean by "import" but perhaps you could describe what you did in a little more detail? Which bundle, where are the waveshells and plugins installed - although,if you used the installer they will be in the correct locations and should work.

    FWIW, Waves 8 is working just fine with Logic 9 here, Waves 7 was fine as well, both in 10.5. and 10.6, on three different Macs. You could of course update to Waves 8, if you have current WUP, it is free of charge.

    kind regards

  4. btoth17

    btoth17 New Member

    well i installed the bundle properly and the files are here, but it doesnt show in logic
  5. rzzz

    rzzz Member

    Are you running Logic 9 at 64 bit? - if so, Waves is only 32 bit so you'll need to restart Logic at 32 bit and run AU plugin authoriser.
  6. georgelegeriii

    georgelegeriii Senior member

    If you go into your waveshells folder in the main waves folder in your applications will find an app called Waves AU reg utility. Run that first, then you're good to go.
  7. davismcgavis

    davismcgavis New Member

    I had been searching online for hours, trying to find a solution to this problem. I was having the same issue - installed and re-installed Waves 7. While Pro Tools 9 recognized it no problem, Logic 9 didn't recognize the plug-ins. Running the Waves AU reg utility totally did the trick. Thanks George!
  8. georgelegeriii

    georgelegeriii Senior member

    Always happy to help. The funny thing is that sometimes the solution is so simple, but in no way obvious...
  9. Van the man

    Van the man New Member

    Hello George, maybe you have a solution for my problem?

    I installed Waves V8R7 and when Logic Pro 9.1.1 starts up, I see Logic scanning all the plugins, but when I want to insert a Waves plugin, there are just a few plugins, from Aphex Vintage Exciter to IR 1. If I go to Ableton, I can see all plugins.

    I scanned before launching Logic with Waves AU Reg Utility and that went well (352 AU in 124 plugin files).
    I opened Logic after set up Waves in 32 bit.

    Do I have to update Logic to 9.1.3? I read about a lot of problems with the update, so I'd rather not..

    What else can I do?

    Thanks in advance
  10. georgelegeriii

    georgelegeriii Senior member

    Logic Pro 9.1.6 is fine to use but that would not be the issue in this case I'm sure.

    the waves plug-ins only show up in the 32 bit plug-ins listing in Logic Pro 64 bit, are you sure you are going here to load them? Do they show up in Logic Pro 32 bit?
  11. Van the man

    Van the man New Member


    I fixed it,

    I had to go to the audio unit manager by preferences in logic 32 bit, it took me like 10 minutes to check all the boxes, but it was forth it :) Now I can use them in 64 bit Logic..

Share This Page