1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9: can't make it stop in record.

Discussion in 'Logic 9' started by Gravity Jim, Jul 12, 2012.

  1. Gravity Jim

    Gravity Jim Member

    I'm new to Logic. but this behavior seems bizarre by any DAW standards.

    Going through the tutorials, all's well, but twice now, when I have created an audio track, armed it, set up ins and out, muted the output, etc... I begin reading and it's doing a fine job. But then I cannot get the damn thing to STOP. SPace bar, mouse clicking the on-screen stop button, using the stop on my Tascam console (set up for Mackie COntrol emulation)... nothing. No matter which way I do it. what happens is that Logic skips backward and continues to record. The only way to make it stop cycling back and continuing the record is to quit.

    I don't think I have any kind of cycling controls set in the sequence. Any guesses?
  3. Gravity Jim

    Gravity Jim Member

    Well, I found a clue... it has something to do with the set-up of the Mackie Control emulation. I don't think the set-up instructions from Tascam for making things work with Logic are good. When I disabled them, the problem went away, but now the transport controls on the Tascam till work... as note-on keys. :)
  4. Eli

    Eli Senior member

    Hi Jim,

    welcome to Logic! One (two if necessary) suggestion to try which might help is this:

    Go to your Logic preferences, under the Logic Pro menu in the upper left. Go tot eh control surfaces section, and choose "rebuild defaults". if you have any wonky behavior/corruption going on with your control surface setup; this should re-initialize things. Try this as a first step, as it is fairly non-invasive.

    If this doesn't work, you could try going into your control surfaces setup page in logic and deleting your control surface icon from there. Then have Logic rescan for found models, and it will recreate a fresh instance of it.
  5. Gravity Jim

    Gravity Jim Member

    No joy. I suspect the way Logic handles the Mackie Control has changed, but the Tascam firmware has not. I guess this is functionality I will have to live without if I plow forward with Logic.
  6. Gravity Jim

    Gravity Jim Member

    Here's something: I CAN make it stop in record. If I start the record pass by mouse-clicking on the screen, then everything runs normally... so, clearly, the bad signal is coming from the Tascam. And if I start the record pass from the Tascam, I CAN make it stop, but I have to hit stop AND the PLay and Record buttons at the same time. Same deal with Play... if have to hit both Stop and the Play button to stop the sequence.

    So, the "note off" message" isn't getting through by pressing the stop button alone... you have to press Stop and the buttons you pressed to initiate the sequence.
  7. Eli

    Eli Senior member

    Just a shot in the dark here: See if your Tascam is showing up as a MIDI port on the Physical Input object in the Clicks and Ports layer of your Environment. If it is, drag the cable from that specific node and connect it to a "dummy" monitor object that leads nowhere. This will break the connection of it reaching the sum output, and reaching Logic. It may do the trick.
  8. Gravity Jim

    Gravity Jim Member

    Eli, I gave it a try (after finding the Environment Window!) and the most fascinating thing happened. There was no dummy monitor object, so I created one....

    All of the Tascam's USB MIDI channel ports do show up in the physical objects list, so I ran the two ports associated with the remote functions to the monitor. No change. As a roll of the dice, I ran them both to the Sequencer Input object, also no dice. But I noticed that both times, I thought I had it fixed.... the sequence went into record and stopped, all from the Tascam's buttons. On the next pass, however, it would again fail.

    And that's when I noticed this: I've trained my hand to press the Record button and then the Play button to put DP into record (not required, it's just how I do it). But in Logic, if I hit both buttons together, it works fine. It only fails when I press the Record button FIRST. And I haven't tried everything, but I think this is the ONLY part of the remote layer that fails... I think I'm seeing as-expected fader behavior.

    Peculiar, no?
  9. Atlas

    Atlas Senior member

    Not sure to understand in your last post if after all, you found or not the source of your problem (user-habit-related)...
    Maybe it could be interesting to have a look at the Record mode you are in; check also how the parameters of your different controllers (Mackie, Tascam, etc) settings are in the controller setup window. There could be some incongruencies there. I already had problem with the C4 having the fine control to stick to max value (long story...):rolleyes:
  10. Gravity Jim

    Gravity Jim Member

    No, haven't found the source, just a work-around. I have a support ticket open at Tascam, hoping they can tell me what to change in the Logic set-up or how to tweak the DM3200. But for now, at least I know what to avoid!
  11. j.o.ceo

    j.o.ceo New Member

    Hey Gravity Jim,you helped me solve a major issue over at the Tascam forum a while back hopefully I can help you with this. Go to logic preference-control surface-controller assignments,at the bottom right hand corner right above the learn tab, uncheck the key repeat for stop, play, record and jog wheel.Note, you have to highlight each of those functions in the control panel of the page. Any word on the return of the tascam forum? I really miss that place.
  12. Gravity Jim

    Gravity Jim Member

    Dude, can't wait to try that. As to the Tascam forum, the archives have been saved and a couple if guys are trying to work out the hosting. It will rise again... I'll send you a URL for the underused current placeholder site.
  13. Gravity Jim

    Gravity Jim Member

    Hey! It works! That was totally it!

    I have no idea what problem I could have possibly helped you with at the Tascam Forum, sir, but you nailed this one for me. Excellent! Now it works exactly as it did in DP. Couldn't be happier.

Share This Page