1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9 Midi Problems

Discussion in 'Logic 9' started by mcdj85, Jun 2, 2010.

  1. mcdj85

    mcdj85 New Member

    Hi, so I'm a pretty new logic user on the midi side- i've only been doing some really basic tracking projects, but now I'm trying to integrate some old hardware synths into my setup, but have been having some trouble. I have a Kurzweil PC88 MX, Yamaha S80, and Kurzweil Micropiano running through a MOTU Midi Fastlane, all setup and ready in Audio Midi Setup, but I'm stuck on what to do in logic. I made a PC88 Environment multi instrument, and it recognizes external patch changes and notes, but doesn't send any data. I would love to know how to do this, as I'm making the switch from Pro Tools for personal logistical reasons, but this is a feature pretty important to me. Please help. Thanks.
  3. SubBlack

    SubBlack New Member

    Hello there Senor, I'm a MIDI guy and I'd be glad to help. First off, there are some pretty non-standard conventions in Logic-Land regarding MIDI. You can dial in to your existing AudioMIDI Setup, or you can use Logic to custom define all kinds of setups. So let's talk about your rig for a minute:

    The FastLane has two MIDI in/out ports. But alack, you have three devices; the PC88, S80, and MicroPiano. So my question to you is: How do you have your MIDI rig configured? For example, what's coming in to FastLane ins 1 and 2, and what's going out from FastLane 1 and 2?

    One will note (in this case you, not Keanu Reeves, are the one) that the inspector window is really helpful for this stuff. Go to your Arrange window and click on a MIDI track. You can show/hide the inspector window by pressing "i" or by going to the Arrange window's 'View' menu and choosing Inspector.

    So now look to all those pesky parameters on the left there. You should see two main sections with triangles next to them, the first being 'MIDI Thru' and the next being the name of your MIDI track. If you click on the triangle next to each section, it should show/hide parameters for that section. You still with me, or are your eyes glazed over with confusion?

    What you want to do next is to click on the arrow in that second section, so it shows that MIDI track's Icon, Port, Channel, etc. Here's my guess regarding your problem: You need to click on the PC88 MIDI track, then look at the Inspector window for that track, and make sure that your Port is set to the correct FastLane port. Further along that line of thinking, the next parameter is MIDI Channel. What channel is each device set to, and is this accurately reflected in the Inspector window?

    The Inspector window can be a real timesaver, or a real confuser. You can set a MIDI track's midi interface port, midi channel, program change, volume, pan, key ranges, and all kinds of stuff. I usually turn most of it off and only mess with the ports and channels, but your needs might differ.

    So there are some ideas to get you started. Lemme know if you need more info wouldja.
  4. mcdj85

    mcdj85 New Member

    Thanks for the response!

    The way I have it set up is I have the PC88 Out going into In A on the fastlane, and out A going to the PC88 In, and out b going to the Micropiano, and then the S80 in, so the PC88's the only controller in the setup. The s80's mainly just used for sounds.

    I tried the setting program changes and the inspector stuff, but while it recognized the changes I did from the keyboard, it still didn't send any changes from the program. Maybe I need to try again, but I really hope I can get this working. It's pretty old gear, but I love the sounds, and I know this can work!

Share This Page