Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic 9 with BFD and EZPlayer

Discussion in 'Logic 9' started by Cutrush, Sep 23, 2010.

  1. Cutrush

    Cutrush New Member

    Hello All
    I am new to Logic so I'm a bit behind. I am having lots of trouble getting BFD to run though ezplayer in Logic 9.
    From in Logic I can select EZPlayer on a midi track but I get no sound out of it. The BFD samples seem to be playing, but no sound. If I run BFD stand alone, when I open a kit and click on the drums I get no sound either. So no sound throu BFD and no where to select BFD from within Logic.
    Any ideas?
  3. georgelegeriii

    georgelegeriii Senior member

    Need more info:

    Computer make ram and drives, audio card, version of BFD, ezdrummer, and Logic Pro/Express....

    Asking like you did is like me asking you where I live and me telling you I live somewhere on the planet. Way too vague. :thmbup:
  4. Cutrush

    Cutrush New Member

    Well I do live somewhere on the planet. Although playing with this stuff I wonder sometimes. I've been playing music for 21 years but I'm very new to home recording.

    I have a Quad core i7 iMac with 8GB ram. Built in audio card but I use a Saffire 6 USB interface for recording.
    Logic Pro 9, BFD 1.5 and the latest EZPlayer. Not sure of version number.

    Thanks for your help with my saffire problem, updated driver sorted it out. Eventually. For the first 3 hours after installing it I didn't even get a usb connection light and it would not come up as an option in Logic as an input device. Three reinstals of the driver later it has been working without a hiccup so far.
  5. Eli

    Eli Senior member

    What exactly do you mean by "getting BFD to run through EZPlayer"? What happens if you call up BFD as an audio unit plug-in software instrument on a software instrument track in Logic? Does that work? I see you are using BFD 1.5 and not BFD 2. I wonder if that could be a source of the problem. I only have experience with BFD 2, and it runs perfectly in Logic 9.

    I'm not sure how you are trying to get BFD to interact with EZ Player. The samples for BFD are compressed into data archives. They aren't meant to be accessed independantly from anywhere other than within BFD - at least that's the architecture in BFD 2.....
  6. Cutrush

    Cutrush New Member

    I was told by a freind that you use ezplayer and bfd together. He uses them with Sonar but I want to use them through Logic. If I could take ezplayer (the middle man) out of the picture and just use BFD through Logic I would do that.
    The problem is BFD does not come up anywhere in Logic. On a software instrument track I can't see how to open BFD. EZPlayer comes up under AU Instruments but I cant get BFD to be seen anywhere.
    I also cant find, on BFD, where I select the output. So when I have bfd open, and select a kit and click on the drums, I get no sound. I have seen that when you click on the drums - and click on different spots on the drums, you get variation in the sound etc. I cant get this to happen at all. And not being able to find where I set the output makes it difficult to see if its just a setting or if there is something more going on.
    My mate runs it on PC and Im on Mac. There seems to be a slightly different interface from PC to MAC because when he talls me where to click to select the OP, I dont have that button.
    If all else fails I might have to try BFD 2 and see if that fixes it.
  7. Eli

    Eli Senior member

    Look in the preferences section under the Logic menu (to the left of the File menu) and open the audio unit validation tool. Check to see if BFD 1.5 has passed validation. It sounds like maybe it hasn't . This would explain it not appearing anywhere in Logic despite being installed on your system.

    If it in fact hasn't passed validation, check on the FXpansion site and see if there are any incremental updates to 1.5 that may solve the problem. If not, you may be SOL with v. 1.5

Share This Page