1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic Express 9 and Yosemite

Discussion in 'Logic 9' started by Jon Hobley, Oct 22, 2015.

  1. Jon Hobley

    Jon Hobley New Member

    Hi I have just decided to really try and learn Logic Express 9 after purchasing it ages ago. I have just loaded it on to my iMac and it says it cannot be used with Yosemite.

    Any advice please?
  3. bayswater

    bayswater Senior member

    If you google your question you will see advise to update to version 9.18

Share This Page