Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 logic not chasing control 64!

Discussion in 'Logic 9' started by paulslice, Jul 8, 2011.

  1. paulslice

    paulslice New Member

    logic not chasing sustained notes

    Heya folks

    I've recorded a piano bit, using a piano in Komplete 7, where I just hold down the sustain pedal at the beginning and let it wash the whole way. But if I play back in the somewhere in the middle, the sustain is gone. I checked the MIDI project settings, all control changes are checked, as is Notes, Sustained.

    Any thoughts?

    Cheers - Paul
  3. yelemusic

    yelemusic New Member

    If you start somewhere in the middle Logic might not realise that there was a controller for sustain pedal at the beginning. That's one reason to add a few more of these events every now and then. Also I would think your way of doing it uses up more polyphony than necessary. There should be a setting somewhere in logic that tells it to chase events, to look for controller events that might have occurred before the current cursor position.
  4. Tangra

    Tangra Senior member


    The Midi Chase must work in ANY scenario! As far as I remember there were some CC64 chase issues - sometimes it works as expected sometimes not. Right now I'm away of my Logic and can not try...

  5. Atlas

    Atlas Senior member

    There are several factors that could be at play here... Among others: NI plugin MIDI settings themselves...

    But the first thing I would check is that your initial sustain-pedal-down event (CC#64 - 127) is occurring at the beginning or after the beginning of the song playback.

    You could easily spot this CC position in the Event Editor, normally 1-1-1-1 is the beginning of the playback. If the Sustain controller event position is before 1-1-1-1, then it is set too early to be initially taken into account by Logic.
    However the chase CC function works in cycle playback mode...
    It is also mentioned in the documentation that similar problem will occur with some sample playback instruments (such as drum loops...). The (NI Komplete 7) Kontakt 4 plugin, that plays your piano, is a sampler...

    One easy way to find out if this is the problem:
    Set Logic to playback in cycle mode (lets say from bar 1 to bar 3).
    Normally you should start to hear the sustain-pedal-down effect on your sound on the first repeat of the cycle (and thereafter...).
    If this is the case, then you could circumvent this little flaw, either by creating a pedal-sustain-down event at the beginning of your track or move your initially (and "prematurely") recorded pedal-sustain-down event at the beginning (or a little after the beginning) of your playback.

    If the above doesn't work, chances are that either other parameters in Logic or Kontakt are set to filter out the CC#64. Then you will have to troubleshoot further to isolate the source of the problem...
  6. yelemusic

    yelemusic New Member

    Can it not be turned off? I actually don't remember. But I too have had the experience that sometimes controllers aren't chased, which is why I tend to draw in extra controller events just for precaution.
    As for the sustain pedal I wouldn't keep it depressed for the entire song anyway, cos I doubt that's how a pianist would play it.
    Besides notes don't ring that long anyway, so it doesn't hurt to "reset" the polyphony once in a while.
  7. Tangra

    Tangra Senior member

    It will be nice to create some Logic project (one track only say piano) and record some midi data plus CC64. If it does not work as expected please provide the Logic song here. I want to have a look at the recorded midi region and try here.


Share This Page