Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic Pro 9 / MBox 3 Pro Latency Issues...please help!

Discussion in 'Logic 9' started by Dirtydirtmc, Nov 2, 2011.

  1. Dirtydirtmc

    Dirtydirtmc New Member

    So Im running Logic Pro 9 with my MBOX3 Pro...and Im having latency issues when recording vocals. Ive not had any problems with software instruments causing latency, only with recording vocals. I lowered my buffer size down to 32 and clicked the low latency button on Logic....even tried turning off software monitoring, but cant seem to figure out a way to monitor through the mbox 3. There has to be a way to fix this horrible sucks cuz its not horrible latency, but enough that I cannot record vocals cuz I get all messed up. Please help if you know of any other way I can fix this??
  3. rosco

    rosco New Member

    I'm having the same issues & can't resolve either. The midi latency is rediculous too. Let me know if you have any luck resolving thanks
  4. Cosmik de Bris

    Cosmik de Bris New Member

    It seems as though Avid are having their "issues". The firewire drivers for the M-Audio products are absolute crap and giving a multitude of problems. I don't know about their pro-gear but your post seems to echo a lot of what's going on with other products. Hammer them for support, you've paid your money.
  5. Doug Zangar

    Doug Zangar Senior member

    I have the mBox 3 and you can route any audio through the mBox mixer software and never go into Logic. Have you tried this? If so, do you still get latency?

Share This Page