1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic Pro has detected a MIDI timeout...

Discussion in 'Logic 9' started by dsw67, Jul 5, 2011.

  1. dsw67

    dsw67 Member


    All of a sudden I can no longer launch Logic. It gets as far as starting the midi drivers and then freezes. After awhile it starts and I get the following message.

    Logic Pro has detected a MIDI timeout. Please restart your computer, then relaunch Logic Pro. Etc. If I restart the computer and relaunch Logic, same thing happens.

    The only midi devices I have are the Apogee Gio, and a keyboard which is usually off. I think the problem is with the Gio since the first issue I noticed was that it was no longer responding to Gio's start/stop commands. Any suggestions would be most welcome.

  3. georgelegeriii

    georgelegeriii Senior member

    Remove the Gio and see if you still get it, or launch Logic and make a new song (I've seen corrupt songs do this kinda thing)...

    try and reinstall the Gio drivers if that looks like ti's the problem, and don't forget to open "Disc Utilities" and repair permissions before you do the reinstall...
  4. dsw67

    dsw67 Member


    Thanks George. The project must have been corrupt. Since it was only a couple of ideas I simply trashed it and everything worked again.

    Interesting to note (for me anyway) I uninstalled the Gio software, and yet it still seems to control Logic just fine. I wish I knew more about this stuff.

Share This Page