Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X and the EXS24

Discussion in 'Logic Pro X' started by Bolder, Dec 10, 2014.

  1. Bolder

    Bolder New Member

    Hello All,

    I'm a sound developer and the owner of Bolder Sounds. I have been developing EXS libraries for many years.

    I have had a number of customers tell me of late that with Logic X, the EXS24 cannot find the referenced samples for a number of my EXS24 instruments - even though they are certainly in the folder they download from my site.

    Well - I have been using Logic since the Emagic days. And the last few years I have been using and developing for version 9.

    So - I needed a new Mac laptop and bought a MacBook pro running Yosemite 10.10. I had Logic X preinstalled so I could get right to work and have a clean machine and see what issues my customers are dealing with.

    First of all - the version X looks almost totally unrecognizable to me. I don't mean to be negative, but it look like a gigantic version of Garage Band now - but I digress ..

    Looking through the user guide pdf - I do a search on the topic of the EXS24 and there are a number of entries, but I really don't see simple instructions on 1. Loading the EXS into a channel strip and 2. Where .exs instruments should be stored. I *know* where they should be stored (as in previous versions - Library/Application Support/Logic/Sampler Instruments

    Is there a separate pdf dedicated to software instruments in Logic X? I've found the users guide and the effects pdf guide. But no guide to the software instruments (EXS, Sculpture)? If there is - where might I find it?

    Also - what on earth happened to the EDIT button on the front panel of the EXS24? How do i get into edit mode?

    Thanks for any help!
    Dennis @ Bolder
  3. Markdvc

    Markdvc Administrator Staff Member

    Dennis, I think you need to switch advanced tools on. That is a vital first step in Logic Pro X. AFAIK with systems such as yours with Logic pre-installed, Advanced Tools are switched off. Fortunately it is a preference, so you only need to do it once. Switched on, it will probably start to look like Logic Pro again ;-)

    kind regards

  4. Bolder

    Bolder New Member

    Thanks for the reply Mark!

    I now see the EDIT button on the EXS24.

    My next question is - when I load a default Empty Project - then choose Software Instrument 9apparently you cannot load Logic X with no tracks at all, you must choose something? - the Classic Electric Piano loads by default. How do I change this to the EXS24 with no effects added to the channel strip. It does not seems as obvious as it should be.

    i just want a clean sounding instance of the EXS24 so I can run some tests - no effects at all.

    Appreciate your help in getting me going on this!
  5. willnubu

    willnubu Senior member

  6. Bolder

    Bolder New Member

    Thanks - all really helpful info.

    I'll be back for more later most likely.

  7. Eli

    Eli Senior member

    Hi Dennis,

    Regarding the default instrument that is called up, there is another thing you can do:

    • Create a software instrument track with an empty EXS 24 instrument instantiated.

    • Save it as a patch in the Library. It will show up in a User Patches subfolder.

    • In the Library, with it selected, choose "define as default" from the gear icon pop up menu (see screenshot).

    • Click the "Open Library" checkbox in the New Tracks window when creating future instruments.

    Your new default patch with the empty EXS 24 will be called up instead of the electric piano patch that is the factory default.

    Attached Files:

  8. Bolder

    Bolder New Member

    Thanks for the tip Eli - but I'm not navigating Logic X very well at this point in time.

    Even though you have attached a graphic, I still do not see that area in your graphic. I DO see a gear icon at the bottom of the Library window, but it just says "refresh library". So I've gotta be in the wrong place.

  9. Eli

    Eli Senior member

    Hi Dennis,

    You have to first save the patch (using the save button). To do this, create the audio instrument with the default EXS 24 instantiated. Make sure the blue triangle is pointing to the channel strip settings field. Then press the Save button at the bottom right of the open Library pane.

    The patch you just saved will then appear in a User Patches folder in the Library that will be automatically created. Select the patch there, and then pop open the gear icon menu and choose Define as default.

    Attached Files:

  10. Bolder

    Bolder New Member

    I see - OK thank you!

  11. CSeye

    CSeye Senior member


    It's very cool that you're still developing for the EXS24 which continues to be a powerful yet efficient sampler instrument despite the ubiquity and depth of Kontakt. I also use HALion 5 and Machfive v3 but generally prefer to use the EXS24.

    Having said that, your Bluegrass Banjo with Kontakt scripting still amazes me.

  12. Bolder

    Bolder New Member

    Thanks I'm happy you like the banjo library!

    I'd like to develop further for the EXS. Right at the moment I am working on troubleshooting with Garth at Chicken Systems. There seems to be a bit of a bug in Yosemite and perhaps earlier versions in the way OSX searches for samples and the EXS does not reference the samples even though they are sitting right there on the hard drive.

    It's complicated - so I won't get into it any further and I don't want to pass on any info that may not be correct. So - I need to get this straightened out first with Garths help and then proceed from there.

  13. Colin Shapiro

    Colin Shapiro Senior member

    Well, hopefully we'll see major improvements to EXS24 sometime in the future, because of Apple having bought Redmatica.

    Redmatica had a range of highly evolved software for EXS24 and one hopes that Apple will include advanced features in an upcoming release of Logic.

    +1 vote for Boldersounds - great stuff !
  14. Bolder

    Bolder New Member

    You know I've been working with Garth at Chicken Systems for the last few weeks on this issue. I have had numerous customers contact me telling me that some of my sample libraries load just fine into OS versions prior to Yosemite.

    The conclusion we have come up with so far is simply that the search function in Yosemite 10.10.1 is broken!

    I will not go into detail about our testing process-but to put it simply the Yosemite search function cannot find samples that is sitting right there on the desktop.

    If someone from Apple is following on this forum or if anyone here has a connection at Apple we would love to pass on this information to them.

    I wrote Bob Hunt a brief email this morning asking him if he was still at Apple and if he could get us in touch with someone in regards to this problem.

    We have tried building a workaround into Translator regarding deleting info chunks. However when we bring these samples back into Yosemite, it still cannot see them.

    Of course this issue is bound to affect a great deal more than just making music on Yosemite and hopefully someone at Apple is listening.

    Dennis @ Bolder
  15. CSeye

    CSeye Senior member


    Hopefully, you'll be able to make a direct connection. But in the meantime, you can provide the specifics via the link within Logic. See attachment.

    Attached Files:

  16. bayswater

    bayswater Senior member

    I noticed the recent item function in the Apple menu doesn't work either. Lots of files that have been opened, edited and saved don't show up there. Maybe part of the same problem.
  17. sluice

    sluice New Member

    after installing the bolder samples on my macbook with yosemite, i noticed that all the samples use metadata with the suffix .gig. so when i search for example "toilet.wav" it could be only found with "water.gig". also when i open this file with quicktime it doesn't show the filename with .wav, but some .gig file. i think that's the issue.


  18. sluice

    sluice New Member

    ok, i've got the solution (if there is still interest on this one).
    download this free app from appstore: Tag Stripper

    drag the bolder folder in the window and run the programm by strip. This removes all metadata, replaces the files in one run and everything is running fine and loads into the exs.



Share This Page