1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Logic9x+Melodyne+tempo changes= no luck?

Discussion in 'Logic 9' started by daveyboy, Feb 6, 2010.

  1. daveyboy

    daveyboy Senior member

    Logic9x+Melodyne+tempo changes= no luck?(Solved)

    I spent most of the day today trying to figure this out. I've been using the upgrade of Melodyne Editor since it cane out without issue. But, I don't think I had songs with tempo changes in them (but, maybe I did..not sure). This song has 3 tempo changes. When I transfer the vocal into ME all is well until I play back. On play back it's out of sync. I then tried fixing it using the variable tempo as per the manual's instructions. No luck there either. I tried playing back the whole 7 minute long track from the top, and, I played it back just from the tempo change spots. There's only 3. For some reason I didn't think I'd need to do anything special for ME to follow tempo changes that were there from the beginning. Finally, I made a new conductor track in logic with just one static tempo and yes, it tracked fine and stayed in sync, until I re instantiated the original tempo track of course. Also, I would get some hard freezes where after I would stop Logic after transferring Melodyne would freeze and produce just a black screen where the plugin window should be. I would then have to force quit. This happened most of the time.

    So, is there a special trick to get ME to behave properly in any tempo change situation? Also, do multiple meters have anything to do it as well? Thanks for any help.
     
  2.  
  3. HKC

    HKC Senior member

    This has been a problem with melodyne forever but since audiofiles don't change with the tempo the workaround is fairly simple. Lock all tracks to smpte, use the alternative tempo feature and just set it up without any tempochanges. The song will play back as it should because the tracks are locked. Melodyne the tracks you need to melodyne, bounce them to audio and revert to the old tempo, then unlock and you're done.
     
  4. daveyboy

    daveyboy Senior member

    Solved (I think)

    Thanks. Yeah, this is something I did. But, I also re read the FAQ page about Logic and I think I was just doing things incorrectly! It says to "punch in" using the Transfer button. I know I've done that, or, I've hit it before I pressed play in Logic. I just never really thought about it one way or another. They say for things to be accurate you need to punch in while Logic is already running. Sooo, that's what I did. I let the whole track play and do it's thing "as is" and after getting through it it seems that ME is perfectly in sync! In my case I don't think I had ever gotten the track into ME correctly and thus was trying to resync things. But, if I would have just done this method from the beginning everything would have been fine. I'll do this from now on. I hope this is all there is to it. Hopefully I'll stop someone else from banging their head against the wall.:brkwl:
     
  5. HKC

    HKC Senior member

    This doesn't always work but of course it's true that you have to punch the tranfer in for it to work at all
     
  6. orcasound

    orcasound Member

    I've been using melodyne plug with dp for years- just moved to logic in the fall... Noticed same thing that after transfer if files into melodyne _they would play out of sync- celemony has solution on their siteS
    - for melodyne plug - make sure you start your host playback first before you hit transfer on melodyne plug ... so workflow - stArt playback on host sequencer - then initiate transfer on melodyne plug in.
     
  7. daveyboy

    daveyboy Senior member

    I've literally spent over 7 hours on this problem now and.....figured it out! I won't bore you with the details, but, I discovered that the tempo change wasn't the issue. As long as I hit transfer after playback, as suggested above and by Celomony, Logic would indead sync. But, if I went to punch in on Melodyne later, or add to my selection, things got way out of wack. The thing that made it work for me was to make sure my TIME SIGNATURE was set to just 4/4 (although maybe that doesn't mater). This song has multiple time changes that apparently make Melodyne crash and misbehave. If I fly it in with a simple time signature then it's fine. I can then put the "complicated" time signature back after I do the first transfer and it still seems fine after that. Time will tell if I've truly fixed this but for now I'm happy.
     
  8. gmomo

    gmomo New Member

    A Solution

    This is how I fixed the 'out of sync' problem.

    1) Make sure you TRANSFER all the measures with all tempo changes to Melodyne.
    2) Click the orange 'out of sync/broken chain link' button next to the tempo in Melodyne
    3) Choose TEMPO VARIATION
    4) Position the playback head from slightly before the new tempo change and press play on Logic.
    5) After the tempo changes are done, stop the playback in logic. Melodyne should say (ex: if changing from 100bpm to 140bpm) "TEMPO VARIATION 100.000BPM - 140.BPM)
    6) Click ok and stretch audio only if you need to

    Repeat Step 1 to 6 for each tempo change.
    Hope that helps
    Cheers
     
  9. daveyboy

    daveyboy Senior member

    Yeah, its not the tempo changes at all, only odd time signatures. I'm now running the latest version of melodyne in 64 bit mode native. No likey the odd timey.
     
  10. jrm

    jrm New Member

    I was having a similar problem with one song. It was working fine and then I must have changed some setting. After that Melodyne would not keep up with any tempo changed in the song. I tried everything I could think of and Melodyne would still not change tempo.

    Then I found a great tip. I exported one of my tracks as a midi file. Can't remember exactly how, but Melodyne has a function to read a midi file to use as a timing master. After reading that in, everything worked perfectly.
     

Share This Page