Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 LogicPro 9 with Presonus Firebox and MacBook Pro

Discussion in 'Logic 9' started by rirabass, May 21, 2012.

  1. rirabass

    rirabass New Member

    I'm a new LogicPro user with MacBook Pro, using an old Presonus Firebox (2005, when God was a little boy). I've downloaded the current update of Firebox control and mixer from the Presonus site. Firebox lights blue, and system preferences speaker check reveals there's static going through (as well as Macbook alert sounds). No audio output joy when in LogicPro, however. User's manual says an alert would signal when booting up LogicPro indicating an outside midi/audio interface, but no such animal. Wondering if I've put the Presonus updates in the right place; user's manual there says "click and drag the control and mixer to the hard drive." Huh? They're on the desktop now.

    I continue to stare at the screen. Really hard. Is this a recurring problem between Presonus Firebox and Logic? Anybody want to chime?
  3. paulnajar

    paulnajar Senior member

    In logic in Global Preferences/ Audio/ Driver/ Core Audio/ make sure you have firebox selected and not "built in" or anything else. Then click Apply changes in the bottom of the window.
  4. rirabass

    rirabass New Member

    Well, duh. Thanks so much Paul, for taking the time hold an idiot's hand.:brkwl:
  5. paulnajar

    paulnajar Senior member

    You're welcome. Don't feel poorly. We all have to start somewhere...

Share This Page