1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Mackie Control showing hidden Aux tracks of multi-output instruments

Discussion in 'Logic Pro X' started by mk3, Feb 27, 2016.

  1. mk3

    mk3 Senior member

    Hello -
    Mackie Control shows hidden tracks which represent Auxes of a multi-output instrument.
    Those hidden tracks should not appear on the Mackie Control.
    Other types of tracks, like audio tracks, properly do not show on the Mackie Control when hidden in Logic.

    Presumably this is a bug. Anyone else experiencing this? Is there a fix?

    Thank you
     
  2.  
  3. paulnajar

    paulnajar Senior member

    So you're saying that the tracks in question are hidden in your tracks list but they still appear on the Mackie Control? If the answer is yes, then have you looked in the View Menu within the mixer and do you have "Follow Hide" ticked?

    On my system (Mackie Control + 2 x XT + C4) when a track is hidden it also hides on the MCU - this is with "Follow Hide" ticked. It's worked like this for a long time.
     
  4. mk3

    mk3 Senior member

    Thank you for the suggestion, Paul. Yes, I am aware of that setting and it is checked (on). That works fine for tracks which are not the outputs of a multi-output instrument.

    If the hidden tracks are those of a multi-output instrument, they still appear on the Mackie control, but out of order; they appear after the visible (unhidden) channels of the multi-output instrument. Ideally they should not appear at all.

    Any further advice welcome. Can anyone reproduce this behavior?
     
  5. paulnajar

    paulnajar Senior member

    I just tested this out. I created an EXS multi output instrument, used the little + button to create 4 multi outs in the mixer, then assigned the 4 aux outs to tracks in the workspace and used control + H to hide each aux track one at a time. In the track list the aux channels hide as you would expect, on my MCU XT display as I hid Aux 1 it moved in the display to appear after aux 4. Same with the other 3 aux channels so that after hiding all 4 aux outs they were back in order on my MCU display even though they were completely hidden in Logic's Track list. So I guess this confirms your experience as well. Bug!

    One possible workaround might be to create a folder track stack. Then if you close the stack the outs hide everywhere.

    Kind regards
     

Share This Page