1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic Studio apps Mainstage 2.2 using more CPU than 2.1.3?

Discussion in 'MainStage' started by md_sanders, Dec 14, 2011.

  1. md_sanders

    md_sanders New Member

    My current live setup has been working fine using Mainstage 2.1.3 so when I saw 2.2 appear through the app store the other day I thought it would improve things if anything and just installed it .
    However ever since the cpu usage is reading a lot higher even resulting in me having to adjust the latency settings to 256 / 512 from my normal current setting of 128.
    Just to double check things I backed up my system and completely wiped it doing a fresh lion install and logic / mainstage right up to mainstage 2.1.3 again and sure enough the cpu usage was back to a much lower figure with the latency setting at 128. So again I installed Mainstage 2.2 from the app store to double check and sure enough with exactly the same setup the cpu idled around 24% which is a lot higher than under 2.1.3.

    Hardware - Macbook Pro 13" - mid 2009 2.2GHz, 8GB Ram, 500GB HDD

  3. herr_gunstig

    herr_gunstig New Member

    So... is there actually a problem with drop outs or cpu overloads, or does the cpu meter just display a higher idle amount? Maybe the total processing power taken is less while actually playing, even though the idle amount is higher.
  4. mmm42

    mmm42 Senior member

    The CPU bar is different in MainStage 2.1.3 and 2.2, you can't compare them to each other.
  5. md_sanders

    md_sanders New Member

    Yeah just to clarify I used version 2.2 live for the first time at the weekend and the cpu usage indicator was really high but having used mainstage for a good while I have tended to ignore it anyway.
    What I'm more concerned about is that I started experiencing clicks and dropouts which tied in with the cpu usage indicator being really high.
    Fortunately it happened whilst I was sound checking so I ended up sticking the buffer to 512 which solved the problem but obviously i had to compensate my playing with the added latency.
    Now having reinstalled lion and logic again and only having installed a minimal amount of plugins exactly the same thing is happening unless I up the buffer?
    The most cpu heavy patch I have use's the plugin alchemy whereby I have 2 instances of alchemy layered on the same patch but it was never a problem before version 2.2
  6. mmm42

    mmm42 Senior member

    Also let Apple know: http://www.apple.com/feedback/mainstage.html - they are really interested in these cases, because there are always some usage-cases you don't see yourself. Same thing happened with previous versions and they got addressed quickly.

Share This Page