1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Manipulating & handling original source files??

Discussion in 'Logic 9' started by satellite maps, Dec 20, 2011.

  1. satellite maps

    satellite maps New Member

    Hello good folks of LUG,

    This is my first post as I'm brand new to Logic Express 9, but have worked with other DAW's quite a bit in the past (Sonor, Wavelab).

    I encountered an unfortunate and fateful discovery with how Logic Express handles files which i have never encountered with any other DAW. I brought in a file that was 110 BPM and slowed the tempo down to 95BPM and to my shock and horror it changed the original source file as well and I was not able to convert it back. After reading and watching some youtube tutorials i learned you must convert the file once you've imported it into the timeline (or inspector). Once again i've never heard of this with other DAW's. Is there any way around this or is it necessary to basically save a copy with another name to retain the integrity of the original file.

    thanks in advance
  3. georgelegeriii

    georgelegeriii Senior member

    Uh, how exactly did you slow it down?

    I have used Logic for about 18 years now, and can't think of any time I have seen an original file get messed up unless someone edited in the sample editor, and there is a very clear warning that this will happen when done there.

    That said, always make sure Logic copies any external audio files when imported into the audio bin (check your settings for this)
  4. Pete Thomas

    Pete Thomas Administrator Staff Member

    I don't understand this either. Logic will alter the playback tempo of some files, e.g. Apple Loops or some other other files (e.g. from Acid), but not a normal wav or aif file.

    If you record the file in Logic and tick the "follow tempo box" then it will also change the playback tempo of the file. (I'm not sure about Express in this regard though).

    Sop what happens if you change the project back to 110?

    What happens if you play the original file in some other software, e.g. iTunes or Quicktime?
  5. satellite maps

    satellite maps New Member

    thanks for the reply guys. So a little extra insight here that i forgot to mention. I actually imported the file and was messing around with the flex time tool and that's when it changed the original source file in addition to what i changed in the inspector. So Pete, to answer your question, i was not able to change it back and yes it was messed up in QT and iTunes as well.

    if you good folks could just guide me in best practices so I avoid this again that would be really appreciated. I merely want to know when importing a file that i plan to manipulate and/or change do i have to save a copy with a different name so that it doesn't override and change the original?

    thanks in advance
  6. georgelegeriii

    georgelegeriii Senior member

    Flex time doesn't actually do anything other than create a series of markers within the audio file that one can use to alter the timing.

    You can remove these and have your file back exactly as it was.

    Open your audio track that you have flex time enabled. Open the lower part of the inspector, where the region name is, and where it says "Flex Mode" select off from the popup menu.

    Your file should be exactly as it was in the beginning.

    I have just tested the flex time mode, recorded a guitar riff at 100 bpm, started flex time, chopped up the file, and sped it up to 120. In Logic I can clearly hear the loop is playing faster when I playback in the arrange window. If I play back the region in the bin, it's back to 100 bpm, and when I play it in the apple finder, it also plays back at 100 bpm.

    So whatever happened to your file wasn't caused by simply putting the file in flex mode, you must have done something else.
  7. georgelegeriii

    georgelegeriii Senior member

    BTW there is a "copy external audio files to project folder" checkbox in the assets page of the song settings. Make sure that is checked and you will always make a copy of any file you drop into Logic.

    That should resolve whatever this issues turns out to be... you will always create a duplicate that Logic will access and use rather than the original.
  8. Pete Thomas

    Pete Thomas Administrator Staff Member

    George is right, this should not happen due to flex.

    EDIT: however the markers George refers to do get written to the actual audio file: if you look at it in the finder you'll see the audio file was modified at the time either the track it was on had flex enabled, or it was moved to a flex enabled track.

    It could happen if you changed the region length while holding the option key, which time stretches the audio file.

    EDIT: but this would normally make a copy and leave the original file I believe.

Share This Page