Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Mapped Instrument question

Discussion in 'Logic 9' started by eartoyz, Jan 29, 2010.

  1. eartoyz

    eartoyz Member

    I am trying to set up a mapped instrument for drums using several instances of the EXS, one for kick, one for snare,hat,rim,tom,etc....each of these separate EXS instruments has around 64 samples, allowing me to change notes/samples in a mapped instrument and rapidly create different kits.

    The first cabled instrument responds just fine in the arrange page when I go to record, but anything from the mapped instrument cable 2 and up has latency to the point of making this method unusable. I thought it may be an issue with too many samples loaded, etc.. and have even tried this in 64bit mode.
    If anyone here has any information regarding this et up would kindly share a solution it would be greatly appreciated!


    Alan Hayes
  3. Eli

    Eli Senior member

    This type of thing used to be a problem years ago; I believe it was before Logic 7. You had to "trick" software instruments that weren't the currently selected track instrument into "live' mode by putting a dummy I/O plugin on them. But this type of problem got solved ages ago.

    If you are experiencing this on Logic 9, then something is very odd. I highly doubt this has to do with the number of samples loaded into the EXS instances. Sory I don't have nay constructive suggestions for you :(
  4. eartoyz

    eartoyz Member

    9.1 with SL.

    Model Name: Mac Pro
    Model Identifier: MacPro3,1
    Processor Name: Quad-Core Intel Xeon
    Processor Speed: 2.8 GHz
    Number Of Processors: 2
    Total Number Of Cores: 8
    L2 Cache (per processor): 12 MB
    Memory: 10 GB
    Bus Speed: 1.6 GHz
  5. eartoyz

    eartoyz Member

    Thanks Eli!
    The I/O plug-in on each instrument cured the latency problem.
    I tried the mapped instrument in a brand new song and still get the same behavior, if this was addressed in previous versions, it is now an issue again.
    I couldn't find any other solutions other than the one you provided.


  6. Eli

    Eli Senior member

    Well, I'm glad the workaround solved things!
  7. Eli

    Eli Senior member

    Hi Alan,

    Here's something you can try that may work:

    1. Create a channel splitter object in the environment.

    2. Cable your mapped instrument to the channel splitter.

    3. Cable each individual output of the channel splitter to a corresponding software instrument.

    4. Make sure to to leave the "sum" at the top of the channel splitter unconnected.

    5. Inside the mapped instrument, set the "base" parameter for each of the notes you want to direct uniquely, to a unique midi channel, corresponding with the output cabling from the channel splitter.

    6. Make sure each of the destination software instruments is set to the right midi channel.

    This may work better for you and avoid the necessity of the I/O plug ins. OTOH, it may make no difference :)

Share This Page