Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 "Merge" alters region size?!!!!!

Discussion in 'Logic 9' started by Rafa, Nov 13, 2009.

  1. Rafa

    Rafa Senior member

    I'm trying to make a loop out of a badly played percussion track. After I selected a 1 bar that sounded O.K. I copied it to another track so I could tweak it a bit and make it sound tighter.
    After putting the notes exactly where I wanted them I now want create ONE region out of these bits and pieces that has EXACTLY one bar in length - there is the problem. The loop sounds great but it's a little shorter then 1 bar, so I time stretched a sliver of the last bit of silence in this loop, stretched it past the 1 bar line, and then cut the newly created region (time stretched) over the grid.

    Great! Now all those regions have collectively one bar in length! So I all I need is to merge them together to make a loop, right? Not. After merging, my loop mysteriously got shorter then the original, un-merged version. It's not a lot shorter, not at all, in fact it's fairly difficult to see in normal zoom size. I only noticed it a long way into the song, when my loop suddenly sounded bad, and that little bit "merge" took away amounted to quite a lot. Does anyone have a clue of what's going on, or how to work around this?

    Thanks
    Rafa
     
  2.  
  3. Rafa

    Rafa Senior member

    One more thing

    It's 100% reproducible, although the difference in region size varies, sometimes it get larger after merging, sometimes shorter.
     
  4. Eli

    Eli Senior member

    Are you talking about a MIDI region or an Audio region here?

    How did you stretch that last note to make it fit? With flex? Or with regular time compression/expansion?
     
  5. Rafa

    Rafa Senior member

    It's an audio region, and I stretched it with "alt+right corner change"
     
  6. Eli

    Eli Senior member

    Hmm, it should work fine. Are you certain that the last bit you time stretched brings it to _exactly_one bar in length? Check the end position in the event list to make certain. And while you're there, verify that the first downbeat is exactly on 1 1 1 1 as well. If they are set correctly; I don't know why it wouldn't work properly.
     
  7. Rafa

    Rafa Senior member

    I didn't exactly time stretched until it got up to one bar (actually I really wanted to do that in the first place, but I couldn't get Logic to snap the right corner to the end of a bar, even thought the opposite works fine). What I did was stretch it past the one bar line and then cut it exactly where I wanted.

    The region start was typed into the event list, so I'm 100% positive it's on the right place.

    You can do that?! Wow, I always wanted to know how to do it. Where is it on the even list? All I see is the start position and what I imagine is the duration.
     
  8. Eli

    Eli Senior member

    In the event list, under the "View" menu, choose "length as absolute position". That way you will view the region end position rather than it's length.
     
  9. Rafa

    Rafa Senior member

    O.K I'll try that, but if after I merge i find out that the it's not exactly one bar in length there is not much I can do right? After it is merged I won't be able to stretch the right corner of the new merged region on the event list.

    I'll see what I can do and I'll report back with my new findings.

    Thanks a lot Eli
     
  10. Eli

    Eli Senior member

    You theoretically can time stretch/compress after the merge; but in reality you will be affecting the whole loop; not just the last "note". It may just do the trick though.
     
  11. Rafa

    Rafa Senior member

    Here's the smoking gun!

    Great - now I have proof it isn't working!

    The three screenshots illustrate what is going on. On the first we see the start position of the first region in the loop. The screenshot shows it starts at "3 1 1 1"
    The second show the end position of the last region, and again it looks alright, end position is "4 1 1 1"
    And finally the smoking gun, a screenshot of the merged region, and this region does not end at "4 1 1 1"
     

    Attached Files:

  12. Rafa

    Rafa Senior member

    I messed up the order of the thumbnails, the last one is actually the first!
     
  13. Eli

    Eli Senior member

    It seems like it's only off for one tick. What I'd suggest is using the repeat regions command (command R) rather than looping it. That way you'll get a fresh start point each bar. And you will never in a million years hear that one clock tick that's missing! :D
     
  14. Rafa

    Rafa Senior member

    That's exactly what I am doing for the past 45 minutes, a bit disappointing though, don't you think? The loop function makes thing look so clean and easy to handle. Now I'm stuck with a mess a bijillion regions all over my session, but's it's alright, that's how our forefathers did it right?
     
  15. Rafa

    Rafa Senior member

    THIS SUCKS! It's really hard to work like this! @#$%D$!!!!
     
  16. Eli

    Eli Senior member

    It's not so terrible. Command R then type in the number of iterations you want. There are way worse things in digital life to deal with. You can also just option shift drag in the Arrange Window to create alias's of the main region. Set your snap value to bars and it's a no brainer!
     
  17. Rafa

    Rafa Senior member

    Yeah... you're right...
    But I hate when I can't have the "normal" way! Especially when I'm already fed up with a project!
     
  18. funkyappledog

    funkyappledog New Member

    Sure thats annoying
    Best other "workaround"
    do a bounce of the original loop ,set the cycle/bounce length carefully as per normal,the new file wlll loop perfectly.
    be just about as quick to do typing this post.
     

Share This Page