Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Midi export nightmare

Discussion in 'Logic 9' started by Edgold, Jun 1, 2014.

  1. Edgold

    Edgold Senior member

    :brkwl: I'm trying to export a midi file to a third party software. (Myriad's Harmony Assistant)) The result's are disastrous!

    For example, a flute track which is short and made up entirely of 16th notes correctly notated in Logic's score view, exports to many different tracks with each pitch in it's own separate track.

    I realize much if not all of the problems may be due to HA but I don't see why some of these different pitch durations become quarter notes etc.

    In desperation, I'm thinking of trying to print them in Logic but I have no experience doing this and from from what I heard, the results are only soso.

    There are three things involved here: Logic, Vienna Symphonic Library samples and HA. And I have a whole mess of scores I must send soon.

    I've tried to change the MIDI preferences in Logic but this doesn't seem to help.

    In other words, any help would be appreciated!
     
  2.  
  3. Peter Ostry

    Peter Ostry Administrator Staff Member

    I don't know why you want to export to Harmony Assistant, but here it works.

    Logic 9.1.8
    Harmony Assistent 9.6.2

    Exported two selected regions (two tracks) as 2 Midi Files. Imported as "Midi (*.mid)" which created new files. Created a new HA file with 2 staffs and copy-pasted from the imported files. I think I could have used a 2-track import as well, but I think normally you would prefer to move the notes to a sheet with a certain view. Therefore the copy-paste action.

    Looks good, display like in the Logic score with the "Interpreted" option on. Correct tempo display. My crosses converted to b's, but no big changes. In one staff even a crescendo sign at the beginning was created because of increasing velocity.
     
  4. Edgold

    Edgold Senior member

    Thanks Peter but I'm not sure I understand you.

    I am trying to export to HA in order to print scores. Are you saying you successfully exported something to HA or left it in Logic? Should I learn the notation program in Logic?
     
  5. Peter Ostry

    Peter Ostry Administrator Staff Member

    Yes.


    Since I am not very good at scoring and don't write for "score-sensitive" musicians, I am not the man to answer this question.
     
  6. Edgold

    Edgold Senior member

    Peter,

    You apparently used an earlier version of HA and that may have made the difference.

    I wlll have to write to Didier at Myriad and see what he has to say if indeed he knows.

    Thanks,

    Ed Gold
     
  7. Peter Ostry

    Peter Ostry Administrator Staff Member

    I just downloaded the new version of HA and it works the same. With single tracks as well as with a 3-track piece. I am not happy with the result but what you describe does not happen. Must be another problem. Did you probably set notes in Logic to independent or used some voice separation or something like that? Or check the event list, maybe you see some events other than notes that could cause this strange behavior.

    Here is a part of my test score in HA:

    [​IMG]
     
  8. Edgold

    Edgold Senior member

  9. Peter Ostry

    Peter Ostry Administrator Staff Member

    Well, doesn't look good of course.

    Can you put your Logic project with just the flute track on your server, for download? I can try to find the problem. If you don't want to post the URL here, send it by PM or email.
     
  10. Edgold

    Edgold Senior member

    Peter,

    I'm having difficulty doing that but an answer from Didier at Myriad is clearly the clue I've been waiting for. He says there are 4 different channels and I've forgotten how to fix this in Logic. I remember doing that a long time ago.

    Thanks,

    Ed
     
  11. Peter Ostry

    Peter Ostry Administrator Staff Member

    The quickest way I know:

    1. Select the region and open the event list for visual control.
    2. From the local "Functions" menu select a "Transform" function, no matter which one.
    3. In the "Presets" dropdown menu select "Create initialized user set". This gives you a panel with all transformer fields.
    4. Set the channel in the lower row to the value you want.
    5. Click on the "Select and Operate" button. It automatically selects all events and sets their channel.
    [​IMG]
     
  12. Edgold

    Edgold Senior member

    Thanks Peter,

    It works of course.Problem solved!

    Ed Gold
     

Share This Page