1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 MIDI Free Time playback issues in L9?

Discussion in 'Logic 9' started by picto83, Jun 1, 2010.

  1. picto83

    picto83 New Member

    Hi everyone!

    Really hope someone can help with this issue or at least set my mind at rest!

    I just got a job producing an album for a singer songwriter, and we did the first track the other day. I'm running Logic 9 (32bit latest update) on a new macbook pro with a Focusrite Pro 24 DSP interface. Artist was playing a piano part live through Kontakt Sampler (Akoustik Piano Samples) and then laid a vocal over the top. Artist didnt want a click track at all and played free-style.

    I checked before hand and noticed no discernible latency problems with this, and playback seemed fine. When it came to edit the piano part the artist said he didnt feel that what we played back sounded like what he played. I am now rather worried incase something is up as parts seem a little sticky in places and cant figure if a logic problem or just way he played it! So my question is thus...

    1) Would Logic9 playback the recorded MIDI part differently than how it was played live (i.e. playback latency or some MIDI disruption/contamination)

    2) If it is just the way the artist played it on the day, or was new to playing virtual instruments live, is beat-matching a piano MIDI part viable to correct the timing to perfection? (project bpm is sat at 76bpm from when we tested out the click he didnt want)

    I've done a project very similar to this before running a white macbook and Logic Express 8 and had no probs like this. Artist has been recording 20 years or more and I want to be sure I'm not making an obvious mistake:brkwl:

    Really appreciate any advice!

    Muchos Cheers :)

    picto83
     
  2.  
  3. SubBlack

    SubBlack New Member

    I will answer your two questions in a second, but I think the simplified answer to your question is this: There is a difference between an audio track's latency and a MIDI track's latency.

    When you first set up your Logic rig with the Pro24DSP, you probably chose a buffer size. That buffer size is pretty accurate, but only deals with audio i/o. Your Kontakt piano, however, will have to travel through your MIDI system (Kontakt, MIDI interface, etc) , and then after that go through your Pro24DSP audio system.

    I would bet $23 that if you recorded both tracks as audio, and zoomed way in, you would see the vocal track would be ahead of the piano. As a test make a backup of this session so you don't f*ck up the original and open the backup. Record both tracks as audio and nudge the piano fwd or bkwds, it might just pop in to place.

    If not here are some answers to your original ?'s:

    1: Yes Logic might play midi back differently than it was recorded, based on what you have selected in the Inspector window. Click on the MIDI track for that Kontakkkkt instrument. Look at the Quantize parameters, make sure it's set to 'off.' If it was set to something like '1/8 Notes' then your recorded MIDI will play back, but quantized to an 1/8-note grid. Set it to off.

    2. It is possible that the artist is not perfect, and had a few drifty notes. Go to the arrange window and zoom out, both vertically and horizontally. You should be able to get a good view of both the audio waveform vs. MIDI notes, and there you can see where any off-notes occur. If the audio is problematic, you can use Flex Time to fix it, that stuff really works! If the MIDI is off, go to the Piano Roll window and fix any timing issues.

    I got $23 riding on this, lemme know how it works out.
     

Share This Page