1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 MIDI loop when Kontakt track is selected?

Discussion in 'Logic 9' started by slirak, Jun 7, 2011.

  1. slirak

    slirak Member

    OK, please bear with me, I'm a Logic n00b (though not a DAW n00b).

    I use Kontakt Player with Abbey Road 60's Drums. Whenever such a track is played back while selected (rec or not), it behaves as if I have a MIDI feedback loop. You know, like when you have an external MIDI synth with both MIDI In and Out connected and you've forgot to turn Local off in the synth.
    Playback stumbles and CPU shoots way up in the red, four or five times as high as usual. As soon as I select another track, all is fine.

    I've tried to check if this happens with other instruments but if it does, the difference is much more subtle. It probably doesn't.

    So it seems to me that I'm missing something obvious here. Any ideas where I should check? Is it likely to be a setting in Logic or in Kontakt?
     
  2.  
  3. slirak

    slirak Member

    OK, I've now re-installed Kontakt Player and the Abbey Roads library and the behavior is unchanged.

    I've narrowed it down a bit further and it doesn't seem to be a MIDI feedback issue. At higher latency settings playback is stable even when I select the Kontakt track. Doing so still increases CPU consumption considerably.

    It would seem that the Kontakt Player is simply having a hard time with Logic's live mode, but whether this is a Kontakt or Logic issue remains to see.

    The behavior is the same with my Apogee One and with the Mac's internal audio interface and it doesn't matter if I have any kind of peripherals connected.

    Deleting Logic's prefs file didn't help either. I'm looking at a reinstallation of Logic as my next step. But before I do that, I'd really love it if any other Kontakt user could verify that they do not experience this issue.

    It's really easy to test. Steps to reproduce:
    * Create two (or more) instrument tracks, one with the Kontakt Player (with a sound loaded) one with another instrument.
    * Record a couple of bars with both instruments and loop the result.
    * With playback stopped, select the non-Kontakt track and hit play. Take note of the CPU consumption.
    * While still playing back, select the Kontakt track and make sure it gets record enabled.

    If you do experience the issue, CPU consumption will rise when you record enable the Kontakt track. The increase will be much more noticeable if you have short latency settings and if the loaded Kontakt library is rather large.
     
  4. Tangra

    Tangra Senior member

    1. Do you have the same problem if try with some other Software Instrument, or Multi-timbral Instrument or it is a Kontakt Player issue only?
    2. Did you try to cut the "Sum" cabel of the Physical Input (in Click & Ports) or to cut it and patch only one cable from a certain pin (midi IN device you try to trigger the Kontakt Player) to the Sequencer object to check up if it's some kind of Midi feedback?

    A.G
     
  5. slirak

    slirak Member

    Thanks for your reply Tangra!

    1. I don't think so. I say think, because I don't have that many AU instruments to try with and no other sample based AU instrument. I don't see the same behavior with the AU and Logic instruments I've tested with though. So it's probably a Kontakt related issue.

    2. I've tried it now, thanks for the tip! No difference though. And it doesn't matter if I have any (physical) MIDI interfaces connected either. I've tried deleting all MIDI interfaces in OS X's Audio/MIDI setup too.

    Thing is, I've never noticed this behavior before. Maybe the issue was there all the time, but certainly not to this extent, because currently, Kontakt/Abbey Road Drums is virtually useless. I don't use it that much though, so I couldn't say when it started acting up. Ah well, I'll reinstall Logic next. It's not all that hard.

    Thanks for your effort!
     
  6. slirak

    slirak Member

    Nope, re-installing Logic made no difference either.

    It might be something else messing up my system, or it's an issue with the current version of the Kontakt Player (I don't have access to an older version of it).

    Now, I'm not very keen on the idea of re-installing my entire system without a hint if that will solve the problem.

    So are there any Kontakt 4 Player users out there? Using the current version?

    I'd be very, very grateful I you could fire up Kontakt in Logic, load a library, record a couple of notes and see how much the cpu consumption rises when you have the Kontakt track selected during playback. Then press stop (you must do this), select any non-Kontakt track and hit play again. Now is there a considerable difference to the CPU consumption or not?

    Thanks in advance!
    /Jonas
     

Share This Page