Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Midi port problem using Startup dialog

Discussion in 'Logic 9' started by oortone, Jun 17, 2011.

  1. oortone

    oortone Member

    I have a strange error with missing midi ports that seem related to the "Startup/What do you want to do" dialog.

    If you are able to reproduce this error please let me know and tell me which hardware midi gear were connected. Also if there are any virtual midi ports present.

    It's really easy:
    1. Start Logic, create new empty project. Confirm all ports are present in Physical Input inEnvironment>Click and ports.
    2. Save this project under any name.
    3. Quit Logic.
    4. Start Logic and open the newly created project using the "Startup/What do you want to do" dialog by clicking OK with "Open most recent project" selected.
    - Check which ports are present in in Physical Input in Environment>Click and ports.
    5. Repeat 3 (you must quit Logic) and 4 but now open the project the traditional way. Cancel the "Startup/What do you want to do" dialog and use the traditional "File>Open" instead.
    - Again check which ports are present.

    In my case I get only the "sum" port using method 4. but all my ports using method 5.

    If anyone alse can repeat this error it's nothing wrong with my setup but a real bug in Logic and the Startup dialog.

    Otherwise I suspect my MC Mix software which creates four virtual midi ports are confusing Logic somehow.

Share This Page