Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 MIDI Recording Problem when using Physical Input in Environment

Discussion in 'Logic 9' started by pbass2, Oct 30, 2013.

  1. pbass2

    pbass2 New Member

    Hi,
    This is probably simple, but I'm stumped nonetheless. I've set up a Logic file to accept MIDI from a Max/MSP patch, using a Physical Input, and then a Channel Splitter in the Environment. It works fine--I have several instruments in Logic being triggered by MIDI coming from Max, each on a different MIDI channel--no prob there.
    However, when I try to record it, the MIDI won't record. Even when everything is playing along just fine, Logic shows no incoming MIDI in the Transport. In fact, even if I just use say the Qwerty keyboard to play one of the instruments, it plays just fine, but again, no MIDI will record and Logic shows no incoming MIDI. I can't figure it out. As soon as I set up that Physical Input in the Environment, Logic shows no MIDI coming in on the Transport, yet MIDI IS coming in, and the instruments are being triggered. I know I'm missing something simple, but....HELP!
    I'm on Logic 9.1.3. I'm attaching a screen shot of a simple version of the file so you can see how I have the Environment set up, etc.
    Any advice greatly appreciated!
     

    Attached Files:

  2.  
  3. Peter Ostry

    Peter Ostry Administrator Staff Member

    For recording you must also send your data to the sequencer input
     
  4. pbass2

    pbass2 New Member

    Many Thanks. Hmmmm---still a little confused. I'm trying to record multiple instruments simultaneously, so do I route the MIDI through each separate instrument in the Environment to the Sequencer Input? I'm trying that but it's only recording whatever instrument is selected in the Arrange, even though they're all Record-enabled.
     
  5. Peter Ostry

    Peter Ostry Administrator Staff Member

    I would not do it through the instruments. You can use Ornament objects to split the path before each instrument. One cable to the sequencer input, one to the instrument.


    That's normal for Logic. Consult the manual: "MIDI Multitrack Recording". Page 459 in my English PDF manual. You may want multitrack recording by MIDI channel, so check this:
    File > Project Settings > Recording
    "Auto demix by channel if multitrack recording"

    You can also do this after recording or scoring, on any MIDI region that contains events on more than one channel. Search for "demix" in the Manual, the chapter is "Demixing MIDI Regions".
     
  6. Tangra

    Tangra Senior member

    What said Peter in the qiote above plus:
    1. You have to select each track (Instrument) in the Logic Arrange and set its midi channel accordingly: 1 to 16 for each instrument (I guess all instruments are set by default to ch.All).
    2. Before recording you have to arm "R" the all tracks. During recording you will see that the all data is recorded onto the selected track but after you stop Logic the recording region will be auto-demixed to the corespondent previously channelized tracks.
    Hint: You can select the all Instrument channel strips in the Logic track mixer and assign them to a Group. Open the Group Settings and disable all checked options such as volume, pan etc and enable (check) the "recording" one. Name/label the group as "R". The idea is: Whenever you select ANY track of that group the all tracks of that group will be auto-armed putting Logic into "Live Play Mode". You can create another pair(s) of 16 Instruments set to ch1-16 and group them as "R2" etc.
    Do not mess the Environment in that - Logic can record up to 16 midi channels simultaneously!
     
  7. pbass2

    pbass2 New Member

    Thanks guys! I will try all this today. Man, I never even heard of an Ornament object before:) I came to the right place!
     
  8. Peter Ostry

    Peter Ostry Administrator Staff Member

    Yes, we are pretty decorative :hippy:
     
  9. pbass2

    pbass2 New Member

    Hmmm-can't delete a post, but I had another snag but just figured it out!
    Thanks again guys!
     

Share This Page