Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Midi recording timing issue (late)

Discussion in 'Logic 9' started by FUBARd, Sep 29, 2011.

  1. FUBARd

    FUBARd Member

    This may be a stupid question but I cant seem to come up w an answer n I've looked everywhere and found only unrelated topics. links or answers welcome :D

    I have midi input lag in logic durring midi recording from my akai usb controller. theres not a whole lot of lag from the time I hit the key to the time I hear sound at all but when ever I record midi live against the metronome mt playing is pretty far behind where it should be. enough to be getting set back a note when quantize is on.

    so far ive tried the recording offset but it effected nothing as im pretty sure thats just for audio. ive also just tried playing faster but it gets REALLY confusing when youre listening to a beat thats behind you.

    I know there has to be some setting to offset a midi in delay, in fact I've had it fixed before but had to nuke n reload Logic because of a plugin issue. anyone remember how I might fix this?:hippy:

    thanks in advance
     
  2.  
  3. CSeye

    CSeye Senior member

    What is your I/O buffer set to?
     
  4. FUBARd

    FUBARd Member

    128 ish on an 8 core Mac pro. Makes 11ms output delay.
     
  5. georgelegeriii

    georgelegeriii Senior member

    try this:

    Go to preferences> audio> general> and set your plug-in latency to "audio and software instrument tracks".

    Also, make sure you don't have a multiband compressor or linear phase EQ anywhere... they introduce allot of latency.

    Let me know if that worked....
     
  6. Peter Ostry

    Peter Ostry Administrator Staff Member

    So far I understand he asked about MIDI coming too late from a controller. This has nothing to do with audio settings.

    I rather suspect a problem with the controller itself, the MIDI interface, USB, weird MIDI routing or something in the Logic Environment. If the delay is not constant it can also be caused by a MIDI loop or another device that went crazy.

    First, install MidiMonitor and check what's going on in your computer, midi-wise.
     
  7. georgelegeriii

    georgelegeriii Senior member

    Hey Peter... FYI sometimes if the latency settings are done a certain way, it sounds like your audio is late, and not only that, it can go off the grid it was recorded too (you play an 8th note, and it ends up a 16th note late).
     
  8. FUBARd

    FUBARd Member

    Hi, sorry to take so long. I tried just using soft synths w no fx anywhere and the midi timing is spot on or at least more accurate than my playing ;). So I think it's all the dynamics processing I had on the master bus. Odd, even though I had it in low latency mode, there was still mad lag. Maybe low latency mode doesn't compensate for 'lookahead'???
     

Share This Page