1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Midi regions glitchy??

Discussion in 'Logic 9' started by jason.bongiovanni, Dec 17, 2011.

  1. jason.bongiovanni

    jason.bongiovanni New Member

    Hello

    I am having an odd issue where I have midi regions with chords and multiple notes, etc. and that plays fine. When I copy it to the adjacent space several of the notes that begin at the very beginning of the measure do not play. Can anyone helps me figure out how to remedy this? (I completed the latest update to logic but I have had this issue with previous versions)

    Thank you

    Jason
     
  2.  
  3. CSeye

    CSeye Senior member

    Just a shot in the dark, but do any of your MIDI notes start before bar 1 (or the first location at the beginning of the region) or sustain past the end of the MIDI region?
     
  4. jason.bongiovanni

    jason.bongiovanni New Member

    Ahhhh ..thank you so much. It turns out that one of my midi notes extended past the region length. Problem solved. Do you know how I can make the note length snap to its ending?
     
  5. Eli

    Eli Senior member

    Try using the "clip length" feature in the region parameter box. I haven't used it in years, but AFAIK, it is still there. When the check box is enabled, it clips the length of the last note to the end of the region, in the event that it initially extends beyond it.
     
  6. CSeye

    CSeye Senior member

    Eli,

    Clip Length is still there and it works.

    Displayed note length in the Score editor matches the end of a region rather than extending the note across the bar line unless View>Duration Bars is active.

    I would be nice to have some feature to "snap" the end of a note to the end of a region.

    wv
     

Share This Page