Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 MMC with DA-88

Discussion in 'Logic 9' started by doofus, Oct 14, 2012.

  1. doofus

    doofus Member

    I'm in the process of transferring some old DA-88 tapes into Logic, so along with the nightmare of sorting out word clock, TDIF, Tascam sync and various other things I know nothing about, I'm playing with MMC. Long story short, it acts very strangely, essentially sending the DA-88 commands when I click on the transport buttons-just not necessarily what it want it to send. For instance, "play" is interpreted as "fast-forward to the end of the tape", "stop" is interpreted as "stop, but only until the mouse is moved to another position on the screen", etc., etc.

    In addition, there's a paragraph in the manual that states:

    >Control-click the Transport bar Sync button and choose the MIDI Machine Control (MMC) setting in the shortcut menu.

    Choose File > Project Settings > Synchronization, and choose the Transmit MMC option in the MIDI tab.

    Logic Pro supports up to 64 MMC tracks, allowing devices such as the Alesis ADAT to be operated via MIDI machine control.

    Each arrange track can act as a tape (control) track, by selecting an instrument with the tape deck icon (#305).<

    It goes on to say that this "tape deck" track needs to be dragged to the top of the arrange window's track list, however, I've been unable to find the "tape deck icon" instrument anywhere, and I'm wondering if this is part of the problem. Is there a better guide to doing this than Logic's help menu?
     
  2.  
  3. Atlas

    Atlas Senior member

    Have you checked here?
    Take a look at the last row of icons on the picture posted there (third from the left)...
     
  4. TimG

    TimG New Member

    Hi Doofus,

    Did you ever get this working? I am having similar issues with a DA78 HR. Got the tape icon up...but still not getting Logic and the Tascam to run in sync. Let me know.

    Thanks!
    -Tim
     
  5. doofus

    doofus Member

    thanks to the post from Atlas I found the icon but the same nonsense is still happening...the machine will respond to transport commands, but in a crazy way. Usually it will just fast forward to the end of the tape, or alternatively, rewind to the beginning, then stop. Maybe I don't have the sync settings right but I have tried a few different things to no avail.
     
  6. TimG

    TimG New Member

    switched and worked

    Hey, I finally got them synced up. Mine is a DA78 so maybe has more options but I ended up making the Tascam master and Logic chasing it. Midi out of Tascam to midi in via USB midisport to Logic. I can tell you all the settings and if the 88 sends midi out it should work. Let me know and good luck! -Tim
     
  7. TimG

    TimG New Member

    ps. that tape deck icon in Logic only worked for arming tracks. did not give or effect the transport controls on the Tascam when it was set to slave and Logic master. Like I said make Tascam the master if possible.
     
  8. doofus

    doofus Member

    so...I think I got it to work also, but I'm not sure what I did differently. When you say make the Tascam machine the master and have Logic slave to it, what are you doing to cause that to be the setup? Is it just a matter of having the little checkbox checked in project settings/synchronization, the one in the "general" tab that says "auto enable external sync"? I have that checked now, and also the one under it that says "auto detect format of MTC". Also under the "MIDI" tab, there are two checkboxes under the MMC heading near the bottom, "transmit MMC" and "listen to MMC input". I have both of those checked now, but I think when I tried this the other day I only had the first one checked. I have MIDI cables going both to and from the DA-88 and a Unitor MIDI interface, but they were there the other day as well.

    On top of that, when I was trying to get this going the other day, the tape in the machine had not been striped with SMPTE. When I tried it tonight, I used a different tape that had a SMPTE track on it, that I had transferred into Logic last night. While running the tape and the recorded tracks in Logic at the same time, I was able to use the "I" button on the channel strip of one of the tracks to toggle back and forth from the recorded track to the signal coming in from the DA-88, and they were right in synch. If I dragged the playhead to another part of the song, the machine chased until it got to the right spot and then locked right up again with the recorded track.So that's all good.

    The part that I'm not clear about it the master/slave thing. In order to hear the tracks on the DA-88 when I enabled the Logic track with the "I" button, I did have to change the "clock" setting on the front of the DA-88 from "int" to "word", otherwise I just got digital noise at Logic's input (I have a Word clock cable running from the MOTU interface to the DA-88). I thought that for the DA-88 to be the master, that setting had to be on "internal", but it sounds like that's a different thing altogether from master/slave, no? I feel like the terminology is what's screwing me up. So what determines which side is the master in this scenario? Thanks for all the help!!
     
  9. SubBlack

    SubBlack New Member

  10. doofus

    doofus Member

    yes, it has the SY-88 sync board
     
  11. TimG

    TimG New Member

    hey...it seems like everything is checked right for making Logic slave...one thing I did alot through this whole thing was reset the Tascam to factory defaults and start over...if you haven't done that...it helps. Also...the Logic tapedeck icon does not apply to this situation in case you are still messing with that. The Tascam has to be set to send midi. Logic has to see it through the midi interface...I think I saw something in Logic for "Unitor"...a special setting. Will have to check.
    Keep me posted...also striping the tape with smpte is a whole different thing I think. We are talking about chasing with MTC, right?
     

Share This Page