1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Modulation controller response

Discussion in 'Logic 9' started by fadbaguni, Mar 22, 2010.

  1. fadbaguni

    fadbaguni New Member

    Logic is not receiving modulation data from my external keyboard. Cannot find a midi filter on. Help
     
  2.  
  3. Eli

    Eli Senior member

    Go to the Clicks and Ports layer of the Environment and cable up a monitor object right after the Physical Input object. See if any mod data is received there.
     
  4. fadbaguni

    fadbaguni New Member

    Yes - I noticed there is no modulation data being received.
     
  5. Peter Ostry

    Peter Ostry Administrator Staff Member

    Install MidiMonitor and check if the keyboard sends the modulation message.
     
  6. fadbaguni

    fadbaguni New Member

    Thanks - I did that and the keyboard (Fantom X8) is sending modulation data. So I assume Logic is not receiving - or it is not sending it back to the Fantom.
     
  7. Eli

    Eli Senior member

    If you're not seeing it in the Clicks and ports layer, than Logic is not receiving it, Have you gone through your prefs and project settings to make sure it is not being filtered out?

    Also, just to rule out, however unlikely, project corruption: try it in a fresh "empty project" and see if the behavior is any different.
     
  8. Peter Ostry

    Peter Ostry Administrator Staff Member

    Check "Automation Quick Access", turn it off if it is on.

    And check your Controller Assignments. You might have mapped the modwheel to some parameter or key command. Once something is mapped, you do not see it in Logic anymore. To check, just open the Controller Assignments panel in expert view and move the modwheel. If it is mapped, it will show up and you can delete it.

    Mhm, this is about all I know. Together with Eli's suggestions you should find this message unless it vanishes between the keyboard and Logic for some reason.
     

Share This Page