Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Monitoring Vocals

Discussion in 'Logic Pro X' started by Svend, Oct 14, 2016.

  1. Svend

    Svend New Member

    Greetings! I am a Logic Newbie, but have used Garageband for many years. Here is my question.

    I have a Focusrite Scarlett 18i20 Audio interface. (18 inputs, 20 outputs)

    I have a logic project and I added a new AUDIO track to record vocals coming from a TC HELICON vocal processor which outputs a stereo output.

    I have a set of headphones plugged into the Scarlett 18i20

    My issue is that when I sing in the mic, I seem to get a straight vocal sound instead of the wacky sounding TC HELICON vocal processor PATCH I dial up.

    When I play back the record track... it does have the sound I wanted from the TC HELICON vocal processor!

    I want to be able to hear the TC HELICON vocal processor effect as I sing, so it is giving me realtime feedback as I sing.

    I can't really understand why I am getting a "clean sound" when a very modified signal is coming out the TC HELICON vocal processor!

    any ideas?? I hope I explained my issue clearly!


  3. Peter Ostry

    Peter Ostry Administrator Staff Member

    I think this is the standard routing in the Scarlett. Normally people don't want a processed sound but rather the dry signal for monitoring. One reason for that is, that you may get a long delay (= latency) when you monitor through the computer and the DAW with plugins.

    The Scarlett has a built-in mixer, right? Here you should be able to route the channel(s) you want to the headphone outputs.
  4. volovicg

    volovicg Senior member

    Yes Peter is correct. First let's make sure the initial assumptions are correct as well...
    1/ In Logic (preferences-Audio) you have the Audio Interface inputs / outputs set to be the Scarlett - correct ?
    2/ you have software monitoring turned on - correct?

    Open the focus control software and click on the headphone output in the left column ( should be 7-8 ) if you are using headphone output #1

    Now make sure DAW Playplack channels 1 and 2 are included in the the bottom half of the configuration window and that both of those channels are not muted. This will allow you to now hear the post processed software monitoring channel through the scarlets first headphone port.

    Now look at the analog inputs on the top half of the window ( let's say the TC is plugged into 3-4). If 3 & 4 are listed and not muted you will get a mix of dry and wet signal in the head phones. If you don't want any of the dry signal - then with the headphone output selected, mute analog inputs 3&4 . ( this would be 100% software monitoring). If you want only the dry signal, unmute analog inputs 3&4 and mute DAW playback inputs 1&2.

    The key to remember is that Logic's stereo output is routed to DAW playback virtual channels 1 &2 on the focusrite. So if you want to hear anything logic is doing these two channels must be included in what you hear out the headphone mix on the focusrite. (software monitoring). If these channels are muted and the analogue channels are enabled in the headphone mix ( this is direct hardware monitoring)...

    Hope that helps....

    In the picture below... I have my Mic plugged into analogue channel #1 with an echo delay effect (Logic configured for Scarlett input/output).
    Notice for the software (DAW) playback section I have channels 1&2 muted. I am hearing only the dry signal coming into 1 (no echo delay) via the headset.
    If I mute analog channel 1 and unmute Software playback channels 1 &2 - I hear the full echo delay affect without any dry signal.

    Greg V. Screen Shot 2016-10-15 at 10.17.10 AM.png
  5. Svend

    Svend New Member

    thanks for the great feedback...
    I think I answered my own question, in re-reading what i wrote...
    The vocal from my vocal processor is alreadily processed before going into the SCARLETT audio interface... so therefore, the audio going into LOGIC must be the "processed" vocal...
    so I think my issue is monitoring levels, and it is too low for me to hear the audio processed vocal
    I think the key is headphones, so I can clearly hear processed sound while i am singing (due to hearing my own voice more than what is coming out of logic)


Share This Page