Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 7 & earlier Moving from Logic Pro 6.4.3 to 9…

Discussion in 'Logic 7 and older Versions' started by hank alrich, Oct 10, 2009.

  1. hank alrich

    hank alrich New Member

    My ol' TiBook has bitten the dirt. All old projects are in Logic Pro 6.4.3 in Panther (10.3.9).

    Does the newest Logic (9.o.1?) run reliably in Snow Leopard? Because that's with what the new Mac will ship.

    Will Logic 9 import my old sessions?

    Slightly terrified here, as I'm not a DAW natural. (I still miss my Studer. That's not the MIO's fault.) Not really looking forward to a new learning curvature, but death happens.
  3. Petrosil

    Petrosil Member

    As far as I can say 9.0.1 does work reliable with Snow Leopard, provided you do a clean OS install, and all your hardware drivers and plug-ins are Snow Leopard compatible.
    Beware of old software, which you don't exactly know is Snow Leopard compatible. As an example one of the most reported problems: Old Melodyne versions will cause Logic to crash on start because of the outdated Melodyne ReWire engine. Celemony offers an update for this, which one should install before running Logic.
    If they were started in Logic 6: Yes. Logic 9 will load sessions from Logic 5.5 and newer. Logic sessions from versions prior to 5 must be converted in Logic 7 before they can be used in 9.


  4. hank alrich

    hank alrich New Member

    Thank you, Manfred.

    I use only the included plugins plus Metric Halo's ChannelStrip, and a bit of outboard.
  5. Shari

    Shari New Member

    I'm assuming then that Logic 6.4.1 songs will open in Logic 8 as well?
  6. Markdvc

    Markdvc Administrator Staff Member

    Yes, that is a safe assumption to make :)

    kind regards

  7. irelf

    irelf New Member

    I bought Logic 9 and the logic 4 files wont run. Obtaining Logic 7 from where?

    Thanks Manfred.
    I bought Logic 9 and the Logic 4 files wont run.
    So do I now have to by Logic 7 aswell?
    Please save me from my prison cell of logic 4!

    Ian Relf - Melbourne Australia.
  8. Markdvc

    Markdvc Administrator Staff Member

    Logic 8 and 9 can only open logic songs from version 5 up. If you have Logic 5, 6 or 7, open the logic 4 files in any of these versions, save them, then you should be able to open them in logic 8 or 9.

    kind regards


Share This Page