Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Multi-Output Instruments: Bounce Track in Place bug?

Discussion in 'Logic 9' started by mk3, Apr 9, 2012.

  1. mk3

    mk3 Senior member

    Hello again -

    While on the topic of multi-output instruments, there seems to be a bug when bouncing using the command Bounce Track in Place with the option to "Include Instrument Multi-Outputs: As Additional Tracks".

    As long as you have some sound routed through channels 1-2 of the virtual instrument's internal routing, which then comes out through the virtual instrument's own stereo channel strip, all is well. (Normally I do not like to route anything through that 1-2 pair, treating the instrument track as just a MIDI track and using the Auxes and Aux tracks to route out the various submix parts).

    However, if nothing is assigned within the virtual instrument's internal mixer to play via the stereo 1-2 output pair, which comes out of the Logic instrument channel strip, then the first Aux track (normally instrument channels 3-4) will be bounced in place with the name and settings (including instantiated plug-ins) of the Logic instrument channel strip instead of the Aux tracks name and settings. The other Aux tracks will bounce as expected.

    Same problem occurs with Superior Drummer and Kontakt, presumably with other multi-output instruments as well.

    The only work-around I can find so far is to always route some dummy sound through channels 1-2, which then leads to a 1-2 track on bouncing that I have to delete.

    I thought this used to work fine; perhaps 9.1.7 broke the behavior. Anyone else experience this issue? Any suggestions of a more elegant solution?

    Thank you.
  3. CSeye

    CSeye Senior member

    ? Maybe I'm missing something but when I select Bounce in Place: Include Instrument Multi Outputs, there is no option for "As Additional Tracks" At any rate, this produces a single stereo file of all Kontakt output whether or not routed through St.1 which is the instrument track in Logic.

    However when I take the route of File>Export>All Tracks as Audio Files>Multi Output Software Instrument:One File per Channel Strip, then the export process gives me separate audio files for each K5 output. The first aux is named Instr 1_bip. vs drums or whatever. The other aux channels are named correctly.

    However, in my case, the first aux (interment ch 3-4) does not include any instrument channel strip effects if nothing is routed to instrument ch 1-2), even with Bypass Effects Plug-in unchecked.

    Strange that my situation produces similar but not identical outcomes.
  4. mk3

    mk3 Senior member

    Make sure you are using the command "Bounce Track in Place" (Control-Command-B) in the Track submenu of the Arrange window, not the regular Bounce command.

    The window should appear with these options as pictured....
    It's a great feature when it works right.

    Attached Files:

  5. CSeye

    CSeye Senior member

    Thanks for pointing that out. I've simply used the right-click option on selected regions.

    However, even using the command BTIP in the Tracks menu, I end up with one stereo file that more or less seems to relate to which track is selected in the Arrange window.

    Bounce-Replace All Tracks does yield a separate audio file per K5 output. However, the instrument track and the MIDI regions on it disappear. The aux cs and MIDI regions remain intact.

    I can't say if this behavior was different in 9.16 or earlier.

    BTIP isn't working here.
    Export>All Tracks does work.
  6. mk3

    mk3 Senior member

    Bounce Tracks in Place will only work on the selected track(s). So:
    - Be sure to select the correct multi-output instrument track before bouncing.
    - Make sure there is actually sound coming out of the desired Auxes (accomplish this by: 1. routing to the various outputs inside the plug-in instrument; 2. selecting those plug-in outputs as inputs on the auxes in Logic's mixer). Logic will only bounce those auxes with actual audio playing through them.
    - Nota bene!!!!! There must be Arrange window tracks for the desired auxes. If there are not, you may select the auxes in the window and choose Options: Create Arrange Tracks for Selected Channel Strips

    I suspect the latter step might be the key....? Let me know if that does the trick...

  7. CSeye

    CSeye Senior member

    Getting up to speed with BTIP was a nice detour. I can certainly see the benefit of a creating several individual drum audio tracks from one MIDI drum loop on one track that's routed to a multi-out SI like Kontakt5/Studio Drummer in my case.

    I learn something every time I read a forum thread or another. :thmbup:

    My Kontakt internal routing and Logic mixer aux cs assignments are correct. (That was one of the first set ups I worked through when coming to L8 from another DAW).

    Back to your original question: When using the Track local menu BTIP command (with "Include Instrument Multi-Outputs: As Additional Tracks" checked on), and with no signal routed through Kontakt's St.1 output, (output assignments beginning with St.2(1)-3, St. 2(2)-4, etc), the first Logic mixer aux cs (input Kontakt 5 3-4) does end up named Instr 1_bip even though it has a proper name like Kick.

    The work around to this is to enter the first aux name e.g. Kick in the BTIP dialog box Name field so that all resulting new audio tracks (Kick, Snare, Hats, etc) are named as expected.

    But, I cannot reproduce the first Aux track (normally instrument channels 3-4) bounced in place with the ...settings (including instantiated plug-ins) of the Logic instrument channel strip instead of the Aux tracks... settings.

    So, maybe it's not a bug. Then again, I see lots of situations where a particular function is an issue for some users but not others. Strange, but not uncommon.

    Maybe others will have something different to report.


Share This Page