Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Multiple Keyboards in Logic

Discussion in 'Logic 8' started by diazj3, May 16, 2009.

  1. diazj3

    diazj3 New Member

    Hi, this is my first post here, and also new to Logic... so I'm not sure this is the right place. ¿Is it possible to connect two or more midi keyboards/devices and record into Logic so each plays a different set to sw instruments? I'd like to use an Axiom25 and its control knobs and pads as a drum set, plus a Keystation 61 and a Kork NanoPad controller (which I havent bought yet until I resolve this)... each with a different set of sounds. I tried this at an Apple store using ProTools, but it seemed the SW took each keyboard as a single on. Any help on how to do this in Logic? Thanks!
     
  2.  
  3. mibo

    mibo New Member

    it works

    You can set your keyboards to different Midi channels, then in Logic go to Settings => Recording and activate "Auto demix by channel if multitrack recoding" checkbox. Now you record enable the separate Instrument channels (each with a different Midi channel) and record or play those.

    Have Fun,

    mibo
     
  4. diazj3

    diazj3 New Member

    thanks- I'll try it

    Thanks mibo! so I guess I´ll buy the larger yet simpler M-Audio keyboard, and still be able to use my Axiom25 for pads and transpose keys...

    As soon as have both I´ll try this and let you know...

    Thanks again,
     
  5. mibo

    mibo New Member

    I just bought the Axiom Pro 49 which is not bad, although I don't like the Hypercontrol, I just want to use Midi CC to control the synths.
     
  6. leytonnz

    leytonnz Senior member

    mibo (thread hijack)

    why dont you like the hypercontrol ?

    ive been thinking about getting a axiom pro because of it.
    thanks
    L
     
  7. Golden Frog

    Golden Frog New Member

    I have a similar problem here. I have a Roland TD-20 Module connected to a M-Audio Axiom 25, connected to the Mac. I want to track edrums and keyboard at the same time. I tried mibo advice, but I can only hear one of them even if both are record enabled. I disable the "Auto demix..." thing, and put the Axiom 25 on channel 1 and the TD-20 on channel 2, and changed the channels in the instruments track. I still hear both instruments triggered by both midi controllers at the same time.

    So my question is, why if I changed the midi channel on an instrument track, it still plays the midi from a different controller with a different channel?
     
  8. Pete Thomas

    Pete Thomas Administrator Staff Member

    Unless I'm misunderstanding the question, the channel splitter will do this nicely, tutorial and download here
     
  9. Jay Asher

    Jay Asher Senior member

    If "Auto Demix by channel if multitrack recording" is checked and you have i.e :
    1. A keyboard playing Omnisphere, the keyboard is transmitting on MIDI channel 1, and Omnisphere is set to MIDI channel 1 in the region parameters box;

    2. A drum controller is playing Ultrabeat, the drum controller is transmitting on MIDI channel 10, and Ultrabeat is set to MIDI channel 10 in the region parameters box;

    it should all work fine. It does here.
     
  10. Golden Frog

    Golden Frog New Member

    Yes, it works!!! I don't know what happened yesterday. Maybe it was murphy's law... Thanks a lot. Other question, when I record, the names of both regions are the same. They get the name of the track currently selected. Is it like that, or there is a way to give each region the name it should be?
     
  11. Jay Asher

    Jay Asher Senior member

    Yeah, that is what it does.
     
  12. 13th Partial

    13th Partial New Member

    Also working with multiple keyboards

    Greetings,

    I use Logic along with Reaktor and Reason with two keyboards. With Reaktor and Reason, I can "turn off" each of my usb keyboards alternatively between the applications so that one keyboard plays a Reaktor instrument while playing a Reason instrument on the other.

    When I try to do this with Logic, whatever instrument that is recored ready plays simultaneously with the Reaktor or Reason instrument, so I am hoping that what has been suggested here for playing two instruments at once on Logic will work with what I am trying to do as well.

    Any othe suggestions would be appreciated.

    13th Partial
     
  13. Eli

    Eli Senior member

    Go to your clicks and ports layer of your environment and cable directly from the specific Physical Input port you want to use, to the Sequencer Input object, rather than using the Sum output of the Physical Input object. By doing this, you will be able to restrict which keyboard's signal will reach Logic.
     
  14. funkster

    funkster New Member

    Am really puzzled by this, and have tried all the above advice without success. I have 2 keyboards, one with weighted action, one without, and wish to easily play some instruments with one and not the other, sometimes with either at the same time. In particular, I want to play for example, just the internal piano of the weighted keyboard with my right hand, while not triggering the midi instrument that my left hand is playing on the unwighted keyboard ( I don't necessarily need to record both at the same time on separate tracks, but the option would be good).

    I have done as prescribed, and have, for example, set the weighted keyboard to transmit on channel 2, while the EXS24 track that the unweighted keyboard is playing is set to channel 1 (which the unweighted keyboard is transmitting on). I have also cabled directly from the physical input ports in Environment rather than using Sum Output, and can verify the weighted keyboard is transmitting on channel 2 in "Input view" monitor. (Unweighted keyboard is on Port 1, weighted on 2)

    I'm expecting the EXS 24, set to Channel 1, not to respond to my right hand playing the weighted-keyboard which is transmitting on channel 2, but it does.

    I can only stop the weighted-keyboard playing the EX24 if I remove the weighted keyboards midi connection (either from Port 2 of the Physical Input, or physically).

    What could I be doing wrong. An above post says to set the instrument midi-channel on the Region Parameter box, but in the Inspector in Logic 9, the only place I can see to set a midi-channel is below this, and is the Track parameter box.

    it's the same story if I use an internal instrument such as EXS24 or a external multi-timbral instrument. In the latter case I would only expect the keyboard transmitting on channel 2 to play the timbre set to receive on that channel, but it plays timbres on all channels.
     
  15. Pete Thomas

    Pete Thomas Administrator Staff Member

    What, even with a channel splitter? What do the monitors shw you is coming out of each channel output?
    [​IMG]
     
  16. funkster

    funkster New Member

    Well, I didn't persevere with the channel splitter because I could already verify with an environment monitor I was transmitting on channel 2 anyway.

    I say persevere because I couldn't get the splitter to do anything, though perhaps I made a mistake with it.

    While transmitting on channel 1, I took a cable from Port2 of the Physical Input (corresponding to Port 2 of my audio interface) to input 1 of a splitter, then a cable from output 2 of the splitter to a monitor. I expected to see midi from channel 1 converted to channel 2, but there was no midi on monitor. I could only see midi if i took a cable from sum-output of splitter or same output as was being input, i.e. channel 1. In other words, nothing was being converted.

    I attach screen shot (n.b. there is a third keyboard I didn't mention before). However, I'm not sure I see the point of the splitter if i know I'm transmitting on different channels anyway. It seems more like the receiving instrument is receiving on all channels, and I don't know how to change that.
     

    Attached Files:

  17. Pete Thomas

    Pete Thomas Administrator Staff Member

    That looks wrong as port 2 is going nowhere.

    A splitter does not convert (that's what a transformer does).

    Connect both inputs to the splitter, then send one channel output to one exs and the other channel output to the other.
     
  18. funkster

    funkster New Member

    Many thanks for feedback. I realize port 2 should go somewhere after the monitor, I just set it up to show the principle of what I was doing. As I say, it does show something if, for example, the attached keyboard is transmitting on the same midi channel number as the port (2, in this case).

    I'm not quite clear what you mean by connect "both inputs" to the splitter, - the inputs of the Physical Input to the splitter's input, and then the channel outputs of the splitter to the exs's? (Obviously can't be that).

    I don't seem to be understanding the point of a splitter, and would try the transformer, but that doesn't seem the main problem anyway, since I already know I can send midi into Logic on different channels. I just can't seem to get instruments such as EXS and others to respond only to one channel at a time.
     
  19. Pete Thomas

    Pete Thomas Administrator Staff Member

    Sorry, my fault. I meant both inputs from the two keyboards.

    I would do this by creating a MIDI instrument (cha = all) cable to a channel splitter, then cable cha 1 to EXS 1 and cha 2 to EXS 2. There are other ways, but I find this works, is easy to see what's going on and bypasses certain (ahem) bugs.

    (see the image I linked to, you can download the environment - it will work!)
     
  20. @ndy

    @ndy New Member

    Thanks Pete!

    I have been complaining about this issue since I got into Logic. The channel splitter is the key for this work around. I still wish we could assign separate ports to individual instruments like in other programs. :)
     

Share This Page