Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 New imac 2.93GHz i7 slower than both the old 2.8GHz i7 and intel Core 2 Duo 2.2Ghz

Discussion in 'Logic 9' started by www.ShaMANoiD.com, Apr 9, 2011.

  1. www.ShaMANoiD.com

    www.ShaMANoiD.com New Member

    My Spec 2.93 Ghz Intel Core i7, 4 GB, Logic 9.1.3 OSX 10.6.7

    My new i7 with higher spec (2.93) is running substantially slower than than my old i7 (2.8), and is even having with Logic more frequent out of memory errors, and CPU overloads than my 3.5 year old macbook pro dual core (4gb Ram)!

    Something is not right!

    Also I get the spinning rainbow ball alot! Compared to my old macbook pro and older i7.

    I have tried switching Logic from 32bit to 64 bit, with not much improvement.

    I have tried running logic with 4, 6 and auto processing threads without much improvement (auto would crash the system, 6 would be glitchy, 4 and 2 about the same)

    The weird thing is I originally bought the older imac i7 2.8Ghz and I WAS BLOWN AWAY how fast, snappy, and powerful it was. However it died on me and apple could not fix it and superbly replaced it with the new i7 2.93GHz
    I noticed my old i7 got extremely hot and I suspect it 'blew up' and I feel than Apple may of 'clocked down' the new i7's or done something to them I do not understand. If anyone can shed some light on this I would be most appreciated.

    Also is there any tests I can do to check my machine is function correctly other than the hardware test?
     
  2.  
  3. georgelegeriii

    georgelegeriii Senior member

    first, you should really upgrade your ram to 8 gig or more, it will make a big difference.

    Are you running big ram required plug-ins like BFD or Ivory, or VSL with lots of articulations? Ram on Logic and Snow Leopard seems to only be able to access about 1.7 gig before all heck breaks loose, and these plug-ins in particular and very problematic.

    Have you tried to open Activity monitor and seen how much ram you have available when these errors start? Or how your CPU meters look?

    This kind of stuff also may happen with bad ram, which seems to be happening more often than it used to.

    There are a number of things you can look at, but really I suggest going to an apple store and seeing if their floor models seem as buggy. There is the Logic demo session that comes with Logic, take that on your machine, and edit it, copy and delete stuff, add more instruments, some green apple loops (they are VI loops and require more CPU) and get a feel for how your machine works, then at the apple store, attempt to do the same kinds of things and see if it works in a similar way.

    Anyways, there are a few things to look at.
     
  4. www.ShaMANoiD.com

    www.ShaMANoiD.com New Member

    Many thanks for the time for your reply.
    I did an extensive test of ram using memtest and seems the ram is ok.

    I did a bench mark test from
    http://www.gearslutz.com/board/music-computers/371545-logic-pro-multicore-benchmarktest.html

    I found using 8 threads gave me the best results 62, where most people get 74 for a machine like mine. But this does not test the ram.

    Using 2 or 4 threads gives 31. But then running 8 threads my logic quits more.

    I was told that even if you install more than 4 gig logic can only access 4 gig away. Is this true?

    Thx again!
    S
     
  5. georgelegeriii

    georgelegeriii Senior member

    Logic can run in 64 bit while using Snow Leopard OS and use all the ram your machine has, so whoever told you Logic could not use more that 4 gig of ram was misinformed.

    Have you tried from the start again: wipe your drive, reinstall the OS then Logic and see if you still have the issues? If so, it's the hardware, if not, something is/was messed up with your OS (which I have seen in the past... a Mac that was running poorly until it was wiped and redone).
     
  6. www.ShaMANoiD.com

    www.ShaMANoiD.com New Member

    Thanks again George.
    You are right, my friend was unaware that logic was now 64bit as he is a Protools guy. So really good to know. Also I was informed of this fact before logic went 64bit, to this info was stuck in my head.
    Many thanks for pointing this out. This is really important.
    Also I have just learned another reason why my old macbook pro was having less memory errors. Apparently the has the imac uses more ram for the video than a old macbook pro.

    Many thanks, I think you just talked me into buying more ram.
    I really appreciate you taking the time to answer this.
    -Stef
     
  7. Staircase2

    Staircase2 Member

    Personally I think you should talk to Apple - maybe there is a problem with the unit they sent you as the replacement.

    Before you go doing anything as drastic as uninstalling everything on your machine it makes more sense to check out that your machine is working as it should.

    The simplest answer is usually the best,

    Love&Peace
     

Share This Page