1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 newly recorded audio is "protected" in Sample Editor

Discussion in 'Logic 8' started by magma, Sep 19, 2009.

  1. magma

    magma New Member

    I have Logic Pro, 8.0.2, running on OSX 10.5.8, Leopard.

    Here's my problem:

    Often, when I record a new audio track...
    it's like that new audio region is "protected" in Sample Editor.

    In Sample Editor, I cannot edit or delete or cut any section out of that newly recorded track. Can't trim or fade-in or fade-out. Nothing --- except "copy", which is non-destructive.

    The only way Logic lets me edit is...

    if I save the Song File, quit Logic, and then reopen the Song File.
    And only THEN can I delete parts of the audio.

    (Another silly work-around is for me to "Convert Regions to New Audio Files" --- which is basically taking the AIFF I just recorded + creating a new copy of that AIFF. And then I am able to edit this new copy of the AIFF. Still... it's an unnecessary process.)

    I've also had the same Sample Editor problem, but with a twist:

    I did not record any new audio.
    I simply imported an existing AIFF from my desktop.

    And then in Sample Edit, it wouldn't let me edit that imported AIFF audio.
    (Just as before, the only option in Sample Edit was "copy", which protects anything from being deleted.)

    I had to save the Song File, quit Logic, and then re-open that song file.
    And only then could I actually edit that audio.

    Even more frustrating: this "error" isn't consistent.

    Sometimes i can record new audio + edit that audio immediately in Sample Edit, (without saving + restarting the program.)

    But oftentimes, the error is in full-effect.

    Has anyone else experienced this?

    I find it demoralizing, not being able to immediately edit newly recorded audio. Makes me want to get out my old G3 iMac and power up Logic Platinum 4. I never had problems like this in OS9.
  3. georgelegeriii

    georgelegeriii Senior member


    I think you are recording in to a take folder. If so, the audio would be protected like you suggest. When you are done recording, look at the track, and see if you can see a little open close triangle at one end of the track. If you can, right click on the track, and unpack folder.

    IF this isn't the reason, Sorry, nothing else I can suggest,

    George Leger III
  4. Eli

    Eli Senior member

    FWIW, I experience the exact same thing when importing the audio from a quicktime movie. For seemingly no apparent reason, sometimes the file is "protected" and changes in the sample editor cannot be executed. And other times it works perfectly. Quitting and then relaunching Logic solves it every time. It's a PITA, but a simple enough work aroudn that I can live with.

    And on a related note; since L9 I've been getting random "file not found" messages when importing QT audio. I can easily manually bring it in through the Audio Bin; so that's an easy enough work around. But it's weird. Sometimes it imports properly, sometimes it doesn't!
  5. magma

    magma New Member

    Actually, I just figured it out, because i was looking on forums for another issue, which turned out to be the core of my problem.

    Often, when trying to record, or trying to save after just having recorded a new audio track, I would get this message: "The read/write permission of only one access path to a file can allow writing. Result code = -49."

    I found my answer at this place:

    "Ok, I fixed both issues by applying the same privileges to the folder (and its contents) where my Logic projects are, including LE projects. Just right-clicked the folder name, selected "Get Info" -> "Sharing & Permissions" -> defined permissions -> selected "Apply to enclosed items" from the drop menu at the bottom of the Info window."

    That worked for me.

    Go to the Song Folder, and highlight + click Command-I (for Get Info), or right click + select "Get Info."

    Then at the bottom of the Get Info window, it says, "Sharing & Permission".

    on my computer, i lists three "users"

    1. me
    2. staff
    3. everyone

    First, I have to click on the Padlock icon, and enter in the administrator password, which allows me to change Privileges. Then I have to make "Privilege" to be "Read & Write" for all three possible users. After doing that, click on the little gear + selected "Apply to enclosed items". That makes it so every file + folder within that folder can be "Read & Write".

    And that makes it so i don't get this "Read/Write" error message.
    Which also makes it so I can edit (in Sample Editor) any file.

    Kind of annoying, the thought of me having to enable Privileges for every possible user.
    I'm the administrator, and nobody else uses my computer. Not sure why I'd have to do this.

    (I wonder if this has anything to do with me deleting all the Apple Qmaster bullshit from my system.)

    Thanks for the all the help.

    I appreciate it.
  6. magma

    magma New Member

    Also, it could be because I have one Logic song file that I use as a template -- with all the tracks + settings that I like. I'll open up this song file, and then save it as a new song file elsewhere, thus creating a new project.

    That could be what's creating these Read/Write issues.

Share This Page