Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 no sound for midi

Discussion in 'Logic 9' started by edurbrow, Aug 3, 2013.

  1. edurbrow

    edurbrow Senior member

    I'm missing something.
    I downloaded a file from a reliable site, but I can't get it to make any sound. I checked midi velocity and volume and they are up. I can hear loops when I click on loops and audition them. The inspector is missing a bunch of things. I wonder why.

    Attached Files:

  3. edurbrow

    edurbrow Senior member

    I should add that the file plays in Quicktime Player okay. When I downloaded it, it automatically opened up in Logic for some reason.
  4. Eli

    Eli Senior member

    Have you checked that the MIDI channel of the notes in the regions correspond to the MIDI channels on your instruments (in case they aren't set to "all")?
  5. edurbrow

    edurbrow Senior member

    If I right click the header name, I can trace the path to a GM instrument, but I don't get how to check the midi channel. Everything is missing in the Inspector as can be seen in the screenshot. There are none of the usual Sends or places to check. It just says Rev and Chor above the automation indicator. If I open another Project it is fine.
    Must be something about downloading a MIDI file (most likely created on a PC) that, 1. automatically opens Logic and 2. messes with the settings.
    This is not an important project or anything, I'm just trying to understand what is going on.
    Thank you.
  6. Eli

    Eli Senior member

    You're playing it back on a track designed specifically for triggering MIDI devices, not the usual type that we use for software instruments. It's not surprising that this was called up with a general MIDI file.

    Your screen shot is pretty small to see, but it looks like the track parameters aren't showing. Click the disclosure triangle and you'll see the info you ned there. Not directly on the channel strip - which is what you have showing.

    Also, all this type of MIDI object does is send MIDI messages. It does not generate any sound of it's own. Where is it sending the messages to? Do you have an external MIDI module connected to your system? Or is it cabled into a multi timbral software instrument? Or maybe to a channel splitter which is in turn cabled to several individual software instruments? On it's own, it will produce no sound.
  7. edurbrow

    edurbrow Senior member

    Apologies for not understanding. I've never seen this kind of track before.
    Is there a way to change the tracks into the usual software instruments?
    I've disclosed the triangles, but they are on the channel strip. Where were you talking about?
    I reassigned the track to Mixer > output Stereo, but the choices are limited. I can only find Master or BPM Multimeter.
    I just want to create a simple sound to hear within Logic (no external units) and in the future know what to do when downloading a GM file such as this.

  8. Eli

    Eli Senior member

    The simplest thing would be to simply create some software instrument tracks and drag the regions onto them.

    If the software instrument tracks already exist in your project, just control click the track header and choose "reassign track", and navigate to the appropriate instruments in your mixer.
  9. edurbrow

    edurbrow Senior member

    That sounds straight forward.

Share This Page