Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No split stereo files in Logic X?

Discussion in 'Logic Pro X' started by musiclab, Mar 31, 2014.

  1. musiclab

    musiclab Member

    Hi I just upgraded to Logic X from 9.18. I work on a large format analog console, have 48 channels of I/O, and because I don't want to be tied to having to use odd/even pairs, I use split stereo files whenever I need to bounce a stereo file. In previous versions of logic so long as you turned off Universal track mode in the preferences, it wasn't an issue. But in X I can't find that preference, and although Logic will put a split file in the bounce folder, the file it imports into the song is interleaved. So is there a way to use split files in X?
     
  2.  
  3. pkm

    pkm Member

    Right click the split stereo file in the bin, select something like "disconnect split stereo file"
     
  4. stv_collins

    stv_collins New Member

    This reference may have the solution to your problem:
    http://support.apple.com/kb/HT5804?viewlocale=en_US&locale=en_US

    "Logic Pro X handles importing split stereo audio files somewhat differently than previous versions. Depending on how you import the files, they may either be converted to interleaved stereo or left as split stereo."

    (or do what pkm suggested; didn't see his reply before posting mine)
     
  5. musiclab

    musiclab Member

    the problem is when it loads into the bin, it isn't a split file, even though I bounced it as a split file, so right clicking doesn't even give me the menu option you're talking about I get "copy convert"
     
  6. musiclab

    musiclab Member

    it looks like this is a bug
     
  7. stv_collins

    stv_collins New Member

    I agree it is flaky. I created a split stereo AIFF with the output panned hard left, so I could easily tell the difference between the L & R files. I tried the various ways of importing the files listed in the Apple support document. The only one that seemed to work was the last one - drag each of the split stereo files into the Project browser (not directly to the tracks area) from the finder. From there I could drag & drop the individual files from the project browser onto a track & they display & playback as they should.
     
  8. pkm

    pkm Member

    If it imports as interleaved, you can use copy/convert to make it split again, then do disconnect split stereo. Kind of a pain, I know.
     
  9. musiclab

    musiclab Member

    actually no you can't when you do that the new file in the browser is STILL interleaved. I spoke to Apple today hopefully there will be a fix soon
     
  10. pkm

    pkm Member

    Not for me, I've done this many times when I get split audio from a QuickTime and want to put dialog and temp mx on separate tracks.

    EDIT: it actually might not show up when you right click, but it's in the edit menu in the bin.
     
  11. musiclab

    musiclab Member

    are you sure you're in X? This always worked fine in 9.18 and every version before so long as you had Universal track mode deselected in the preferences. And I think you misunderstand you can't even get a split file into X, it converts automatically into an interleaved file. You can kind of trick it if you drag the .R file in first but even that doesn't reliably work. So you can't disconnect it's not split. I'm well aware of the disconnect file menu and it's unavailable unless you have a split file to start with. Also if I have a split file there is NO need to disconnect it, I can have the left side coming out of say output 6 and the right coming out of output 7, which is an example of what I need to be able to do.
     
  12. pkm

    pkm Member

    Yes, I'm sure. I did a tv show all in Logic X and did this a lot.

    Trust me, give it a shot. Import the file, copy/convert it into split, then disconnect selected split stereo files.
     
  13. musiclab

    musiclab Member

    I appreciate you trying to help, but what you don't seem to understand is when I copy /convert the file to a split file, the new file in Logic's browser is STILL interleaved. It NEVER makes a split file, there is a split file in the bounce folder, but no matter what you do it comes into logic as a interleaved file. So there is no way to to disconnect the file. Also if this was working properly as it did in every other version of Logic once you unchecked Universal track mode in the preferences, then there wouldn't be a need to disconnect the file anyway. Maybe the earlier versions of X worked properly, but this is a bug. I was on the phone with Apple and got pretty far up the tech support ladder today and they reproduced my problem and with 10.06 they couldn't get it to work right either. So supposedly they are contacting the software guys for a fix. BTW even though the list has me as a junior member, I've been using Logic since version 1.6 so it's not like I'm a novice, I just don't hang out on this forum.
     
  14. pkm

    pkm Member

    Ah, gotcha. You're right, I didn't understand that. Last time I did it was in 10.0.5. Just tried it in 10.0.6 and you're right, copy/convert isn't doing it. Best I can say is to rename the new split files in the finder (take out the .L and .R, and replace them with "Left" and "Right" or something) then bring them back in.
     
  15. musiclab

    musiclab Member

    Hey you know what, that is a great idea and it works. Hopefully they'll fix this. I just downloaded X last week, and they gave me 10.06, and had a client want me to use X on his session sunday, and I had to comp a pile of background vocals into stereo pairs and ran into this.
     
  16. pkm

    pkm Member

    Me too! It's been a few months since I've worked to picture so I didn't know what I was missing. Sorry for the misunderstanding earlier.
     
  17. musiclab

    musiclab Member

    thanks for trying and your last suggestion which works and will be my workaround till they fix this.
     

Share This Page