1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Only Inputs 1-2 available on Saffire 56

Discussion in 'Logic Pro X' started by M57, Jul 31, 2015.

  1. M57

    M57 New Member

    I've been using the Saffire with Logic X fine for a while always able to track more than 2 at a time. Now I'm only able to record from inputs 1-2.

    So for instance, I can see levels on tracks 3 and 4 the Saffire unit as I play. One of the track inputs is set to 3-4 from a previous session in Logic. I can't select it now on any new tracks because ALL inputs except 1 and 2 are shaded. And of course, when I go to record enable any track assigned to inputs 3-4 I get a message:

    "No input source selected!"

    I love the exclamation point. It's telling me I'm a dummy, right?

    I have also notice that for the last month or two the output router on the Saffire sometimes goes to default (OFF) and I have to reset my outputs, so I'm suspecting the problem is on that end. I reinstalled the software for the Saffire, downloading the most recent from the website and that didn't really seem to help. Did it again today with no love of course. Do I need to do anything more drastic? ..for instance uninstall the Saffire first? If so, how would I do that?

    Thanks
     
  2.  
  3. M57

    M57 New Member

    Solved my own problem and yes, I am a dummy.

    Don't know how, but in Preferences - Input Device was set to 'built-in', not Saffire.
     
  4. Del Hollingsworth

    Del Hollingsworth New Member

    If at any point you open a session without the Saffire powered up Logic seems to like to select the system default audio. With the Saffire Pro 40s I'm using I purposely set up the Pro 40s as my default audio device on my Mac. But every now and again I do a stupid and fire it up without the Saffires running and get the same issue.
     

Share This Page