1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PDF shadows

Discussion in 'Logic Pro X' started by joegold, Oct 15, 2013.

  1. joegold

    joegold Member

    I've seen a few posts on a few forums about PDFs of the Score Editor not printing properly, with music font characters having some sort of a drop shadow text style erroneously applied to them.



    I'm trying gauge how many people are experiencing this and I'm hoping that someone may have discovered a way to fix this when it does happen.

    I've been thinking of upgrading to Logic X from L9 but scoring is the main thing I do with Logic and if PDF printing is all munged up it won't make sense for me to do.
  3. Colin Shapiro

    Colin Shapiro Senior member

    If you want this to be fixed, add your voice to the many users that have complained to Apple.

    Send feedback:

    As far as I know, there is no fix. We have to wait for Apple to release the fix in an update.
  4. joegold

    joegold Member

    Yet it appears that not all users of Logic X are experiencing the same issue.
    It would be nice to find out what the common denominator is with the folks who are having the problem.
  5. joegold

    joegold Member

    Any more info on this yet?

    Any sense as to how widespread the problem is and what the common denominator is?
  6. Colin Shapiro

    Colin Shapiro Senior member

  7. joegold

    joegold Member

    I don't own Logic X yet but I can't help but think that this is some sort of a System-oriented font installation problem.

    Has anybody with the issue tried opening Font Book and doing some basic maintenance there like resolving font doubles, etc.?
    If so, did that have any effect or not?

    I'll probably buy Logic X today anyway, but it'd be nice to know that I'm not going to come up against this problem.
  8. joegold

    joegold Member

    I bought Logic X yesterday and I don't see any of the shadows on screen with any PDF files I've generated via the Print dialogue or the Camera Tool.
    I haven't printed anything off to my printer yet but I'm assuming it will look fine when I do.
    Am I missing something or am I just lucky?
  9. Colin Shapiro

    Colin Shapiro Senior member

    Lucky, maybe unique!
  10. geijn

    geijn New Member


    I was waiting for 10.05, hoping the drop-shadow-problem would be resolved....
    but as I see it...: still there....
  11. geijn

    geijn New Member

    what I don't understand is...:
    when I open a score in Preview (with the print-command) it comes out perfectly;
    and only when I export it as pdf it comes out all blurry...
  12. Colin Shapiro

    Colin Shapiro Senior member

    I just did a few tests and when I use the Camera tool, I get a file that looks perfect when viewed in Preview and in Adobe.

    However, when I use Logic's Print command, I get a file that looks perfect in Preview but has shadows in Adobe.

    Obviously I have no idea why this happens…..
  13. joegold

    joegold Member

    Finally I'm seeing what you guys are seeing.
    If someone in one of these threads had mentioned earlier that the problem was specific to on-screen viewing within Acrobat Reader I may not have gone ahead and purchased Logic X.
    But what's done is done.
    At any rate this problem seems to be confined to on-screen viewing across all Adobe applications, including Acrobat Reader, Acrobat Pro and InDesign.
    Apple applications such as Preview and Pages appear to be immune.
    Hard copy printouts from any of the above mentioned applications look fine though.
    The problem appears to me to be limited only to *on-screen* viewing from within Adobe applications.
    So I suspect that the problem is really with Adobe and not Apple, even though PDF is Adobe's baby.

    When I tried to open a Logic X generated PDF in Illustrator it couldn't find Logic's music font, AScore, even though an AScore subset is embedded in the PDF by Logic.
    When I tried to open it in Photoshop I got a message saying that it couldn't display the PDF properly unless I turned off Font Smoothing of Fonts 8 points and lower in the System Preferences Appearances pane.
    But that Preferences pane is no longer used in Mavericks and the replacement for that item is now in the General Preferences as LCD Font Smoothing with no way to specify the minimum size fonts that will be affected
    So I suspect that this problem involves Adobe not yet compensating for the new Preference pane's features.
    At any rate, since printout is not affected, for me, there is no real problem.
    Still, it would be nice for someone somewhere to fix this sometime.
  14. Colin Shapiro

    Colin Shapiro Senior member

  15. joegold

    joegold Member

    Will do as soon as I have a chance.
  16. geijn

    geijn New Member

    I have sent two pdf's to a professional print-shop a use to work with:
    one pdf directly from Logic
    same pdf, imported in inDesign and exported again as pdf

    both pdf's were bitmapped when printed...

    so it is not only an 'on-screen-problem', I'm afraid....

  17. joegold

    joegold Member

    From what I can see/tell the bitmap nature of the graphic is only an issue if you need to enlarge the image beyond 100%.
  18. geijn

    geijn New Member

    no, it looks like a PDF with poor quality
    I did not enlarge the image

    as it seems there is a problem with the rendering to PDF
    I have posted the problem on a forum of Adobe
    but did not get a response yet

    it is SO frustrating!!!
    I worked years and years this way
    and now I am totally blocked in printing my scores...
  19. geijn

    geijn New Member

    I did a lot of research with an Arcobat-expert. He found out that Logic exports the score with a layer behind it; the notes are a clear vector-image and behind it there is a pixel-layer. I don't know how, but I could apply two screenshots where you can see that I removed the note (in Acrobat), and that a shadow-note is still there, in the back. That shadow-note is to delete... so anyone who is interested in a life as a monk.... lots of work here....
    But all together: the problem is in Logic: it generates a pdf with a screenshot-file in the back with it....
  20. joegold

    joegold Member

    This reminds me of the “Preview” image that used to be included with EPS files.
    When printing an EPS file from a sophisticated enough application, you are given the option of including no preview, a low quality preview or a high quality preview.
    The preview is a bit map image that can be seen in a DTP app when the EPSF is inserted on a page so that you can ascertain the content of the graphics and/or text within the EPSF.
    EPS files themselves are printer instructions only, with no info for rasterizing an on-screen image.
    Including the preview makes the file larger and the hi quality preview makes the file even larger but looks better on screen.
    PDF has become the standard now for DTP graphics inserts, replacing EPSF which used to be the standard.
    It almost sounds like when Logic X prints to PDF it actually makes a preview too and overlays that on top of the vector images in the PDF.
    This is a BIG mistake on Apple’s part of course.

    But because Logix X’s PDFs look fine in Apple’s Preview application it’s made me wonder if maybe there’s some sort of a war going on between Apple and Adobe right now, for PDF supremacy, and we’re the pawns.
    Hopefully though, that’s just absurd.

    I’m sure this will get fixed, eventually.
    Just a matter of how long they take to do it.
  21. joegold

    joegold Member

    From bluegrassLogic at the logic User's Group forum.

    "Hi Guys I've finally came up with a work-around to take care of this problem, but unfortunately it involves Adobe Acrobat X Pro (It will also work in acrobat 9 but the steps will be a little different than I describe here). I only have adobe acrobat x for PC (not mac) but I would guess that you have the same possibilities in the Mac version.

    Open your PDF in adobe acrobat X pro.

    Menu "View" --> "Tools" --> "Print Production"

    from "Print Production" click on "Preflight"

    click on "Create PDF layers" and choose "Create separate layers for vector objects, text and images"

    when prompted, save a copy of your file.

    Close the "Preflight" window, close the file and open it again. Menu "view" --> "show/hide" --> "navigation panes" --> "layers"

    hide the layers "text" and "vector objects". The image layer now shows all the grey background.

    Menu "view"-->"tools" --> "content" --> "edit object". Click somewhere in your pdf and Select all (CTRL+A )

    rightclick and select "Delete"

    make the layers "Text" and "Vector objects" visible again

    "File" --> "Save as" --> "Reduced size PDF" and save your file.

    Voila! the nasty gray images are gone and your PDF filesize is reduced significantly [Smile]

    Hope this could be helpful for someone out there, it sure has helped me [Smile] "


    From me:

    "How To Fix LX PDFs With Acrobat Pro 9

    1. Open PDF in Acrobat Pro.

    2. Advanced Menu: > Pre Production > select Pre Flight

    3. Pre Flight window: Select “Create separate layers for vector objects, text and images.”

    4. Click Analyze and Fix.

    5. When prompted Save File.

    6. Close Pre Flight window.

    7. Close file and reopen in Acrobat Pro.

    8. View Menu: Navigation Panels > select Layers

    9. Layers Pane: Control Click on text layer and de-select Show Layer.

    10. Layers Pane: Control Click on vector objects layer and de-select Show Layer.

    11. Tools Menu: Advanced Editing > select Touch Up Object Tool.

    12. Click on PDF image and select all (Command A).

    13. Hit Delete.

    14. Layers Pane: Control Click on text layer and select Show Layer.

    15. Layers Pane: Control Click on vector objects layer and select Show Layer.

    16. File Menu: Save your fixed file to disk.

    17. Open file in Adobe Reader and check that it worked."

Share This Page