1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pedalboard MIDI control problem in Logic Pro 9

Discussion in 'Studio Techniques' started by Atlas, Aug 6, 2009.

  1. Atlas

    Atlas Senior member

    Despite following instructions in the online manuals, something paradoxical is happening with the recording of the pedalboard effects when they are assigned to be controlled in realtime via a MIDI controller. For example, the sound of my guitar sounds processed before and during the recording, as expected. The plug-in react also appropriately and graphically on the screen. But when it is played back, that same track sounds dry, with no effect! However, when I do record without assigning the pedalboard plug-in to a MIDI controller, the playback of that recording sounds wet (with the effect). In both cases, I can record an automation track but again, only the one without the MIDI control assignment will react (soundly and graphically) to the automation track data!? I tried to record using the mouse to actuate the effect (for instance the Wah) and it worked as expected on playback. I think there is something wrong with the MIDI control assignment procedure, but I could not find anything anywhere in the documentation in that regard. I would greatly appreciate any input!
     
  2.  
  3. VonMagnum

    VonMagnum New Member

    I'm having the same exact problem right now. I just setup Logic 9.1 on my September era 2008 MBP (4Gig/500Gig upgraded and running latest Snow Leopard) with a PreSonus and M-Audio MidiMan 2x2 and I have my Roland Digital Piano sending the Midi Pedal data to the Wah effect I want with my Fender guitar. I could have sworn it played back correctly the first time I checked it (maybe not?), but after adding a Midi controlled bass guitar part to the song I'm working on, I noticed there is no Wah modulation at all during the song on playback. The other two effects (a fuzzbox mixed to the wah and a compressor in line after that) seem to be "on" and maybe the "Wah" is on during the song but it doesn't modulate, which defeats the point of the pedal.

    I'm very new to Logic 9, but this is definitely frustrating. I assumed since it was an audio record that the effects were actually being applied to the audio, but that apparently is not the case. I don't know if there's a setting I missed somewhere or what and I'm disappointed there has been no reply to your posting in almost a year.

    I have another weird problem with the MIDI signals being heavily delayed when I start Logic 9 unless I unplug the USB cable (which generates an annoying error message which shows up every time despite me clicking the 'do not show again' box, but when it comes back online, MIDI works perfectly with no noticeable latency.

    Does Logic9 comes with phone support? This might be something to ask Apple about since it's kind of dire, IMO. I'm having trouble parsing this problem in Google to get useful results since the key terms show up constantly on non-related things.

    Edit:

    Ok, I did find the answer after all. Apparently you have to use "Automation" (click on it) and then select the wah pedal's position as the automation slot and then select "Latch" and you can then even edit the data on playback of the existing part by just moving the pedal where you want to. It has to stay selected on latch to play back. I don't see a simple way to delete the data recorded with the pedal (say to do it over again) offhand, but I'm sure I'll find it.
     
  4. Atlas

    Atlas Senior member

    It took me a while to figure it out also but I never bothered to come back since no one ever replied till now...

    Prior recording audio with Automation (of a Wah-Wah in example), you have to make sure that you have set the Automation to either Latch, Touch or Write mode in order to actually record the Pedal movements.
    These Automation modes are selectable from the little box just above the fader/Pan dial of the track (or in the track header once Automation have been activated from the Toolbar at the top of the Logic window).

    Once recorded, when you play back the track, make sure that the Automation is set to Read mode to hear it, otherwise, if left at the other modes you risk to unwillingly edit the already recorded Pedal movement, especially with the Write mode that will erase whatever Automation data that has been recorded.
    The Touch and Latch modes are useful mainly to edit Automation that is already recorded.
    If the Automation mode is at OFF, you will not hear the Pedal movement effect, although the Automation data is still recorded there; it is then only silenced.

    Automation is in fact MIDI data that is used to modulate parameters inside Logic and is separate from the actual audio recorded signal.
     

Share This Page