1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic Studio apps problem with controller assignments in mainstage

Discussion in 'MainStage' started by Invisible Man, Jun 29, 2011.

  1. Invisible Man

    Invisible Man New Member

    Hey everyone,

    I'm trying to run two keyboards through Mainstage 2 -- one is an M-Audio Oxygen 61 which I'm using as a MIDI controller, and the other one is a Microkorg XL. I just want to process some audio from the Microkorg and get some of the Mainstage effects on it. The added hitch is that the Microkorg also has a software platform, which I've been using to design sounds, sending those sounds back to the Microkorg via USB. So the Microkorg is actually acting as a MIDI device too, I guess.

    here's the problem: the hardware knobs on the Microkorg have been automatically assigned in Mainstage. So when I turn the knobs to change a patch on my Microkorg, it also will change the patch on Mainstage, taking me away from the patch that I've set up for for the audio processing. And when I go into Logic to try to reassign the controller, it doesn't even recognize that it is, indeed, using the Microkorg as a MIDI controller.

    So basically I'm trying to delete whatever control on Mainstage/Logic that has automatically been assigned to my Microkorg's knobs which makes it change the patches on Mainstage. Any advice?

  3. Atlas

    Atlas Senior member

    You will have to dig into the Layout parameter setting in MainStage. I think that the MIDI-Controller assignment in Logic is independent from the MainStage one. However you can disable (temporarily) the MIDI-Controller setup in Logic if you want to troubleshoot furthermore.

Share This Page