1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Problems syncing external midi device with Logic

Discussion in 'Logic 8' started by pv_joker, Apr 17, 2011.

  1. pv_joker

    pv_joker Member

    I'm trying to sync my Electro Harmonix 2880 Super Looper with Logic Pro 8 using Logic as the master and the 2880 as the slave. I have synced external devices with Logic before and never experienced any problems.

    I’m getting towards the end of my tether with this and I’m really hoping someone can help. I have the latest 1.5 software upgrade for the 2880 and, as far as I can tell, it is technically in perfect sync with Logic. The 2880 (in ext. clock and quantize mode) is definitely receiving midi clock from Logic via my Motu Ultralite mk3, the looper reacts appropriately to play and stop messages from Logic and does not give any error messages to infer that it is not syncing properly. I have set Logic up to transmit midi clock to my soundcard's midi out and, as far as I can tell, the 2880 is definitely receiving it.

    The problem I have is that when I’m playing back a recorded loop, the tempo seems to waver and create changes in pitch. It seems as though the 2880 is being clever and following an uneven midi clock input. I have read around on the net and have come across a couple of workarounds that suggested to record a blank loop first, re-record over this loop and then let it play back with the volume down for one revolution of the loop (to let the looper ‘settle in’ to the midi clock tempo). Unfortunately I’ve been unable to make this work. Is it possible that the clock coming from Logic is not steady? Or could it possibly be a problem with my soundcard not transmitting midi clock correctly?

    I’m certain that I can’t be the only person who has ever experienced this problem but have been unable to find much info regarding it. Any help on this would be much appreciated. I have a gig coming up very soon and I’m starting to freak a little bit.

    Thanks.
     
  2.  
  3. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    I have no direct experience with the 2880, but marketing says it is a standalone 16 bit 44.1 recorder. You were not specific about why you need to connect a computer to it when it has its own audio clock to play back the loops you can record onto its own media. What are you trying to accomplish that requires the interconnection to your MOTU Ultralite?

    Runaway MIDI can be caused by more than one master clock. MIDI clock is not as steady as LTC, but should work in a pinch, if you need it.

    The "sync window" in Logic has always been mystical to me, as the reference guide presumes the reader already knows which radio buttons will work for many possible different setups. Tight sync between external devices may require hardware synchronizers.
     
  4. pv_joker

    pv_joker Member

    Sorry, I probably could've been a bit more explicit. I'm trying to sync the looper with Logic / my Motu so that I can have midi playing from logic and record loops live with the 2880. The 2880 can be set up to ignore its internal clock and synchronise with another midi clock.

    I haven't looked into the possibility of using LTC, I'll definitely be trying this. I'm pretty sure I've set everything up to use Logic's clock but I'll do an idiot check and make sure I'm using only one master.

    Thanks for your help, I appreciate the speedy response.
     
  5. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    Can't guarantee this will work for you, but these are my settings:

    In Logic's main menu, click "File" and select -> "Project Settings" -> "Synchronization," then click again.

    Under the "General" tab, set "Sync Mode" to "Internal." Make sure there is no checkmark for "Auto enable external sync."

    I use a frame rate of 30 for audio only (that is, when there is no accompanying video). Enter a checkmark in "Auto detect format of MTC." Set "Validate MTC" to "always."

    Under the "Audio" tab, the MTC should be displaying 30 fps and the sample rate should be displaying 44100 Hz. For "Audio Sync Mode," set "Core Audio" to "External or Free." (In the "Audio-Midi" applet of OSX, your Motu Ultralite's clock should be set to "Internal.")

    Under the "MIDI Clock" tab, there should be no checkmarks. A "round-trip" MIDI connection from the Ultralite to the 2880 should sync the MIDI to Logic.

    If you click on the "MIDI Sync Preferences" shortcut button, it will take you to the "Sync" tab of Logic's global MIDI setup. I use the default settings there, but you may have to experiment. My delays are all zero, and there are checkmarks under "Transmit Locate Commands When" for "Pressing Stop Twice" and also "Dragging regions or events."

    In spite of what it may sound like, the master clock in this setup is the clock in the audio interface whose drivers are loaded. It should sync up your MIDI to the 2880, but may not sync any audio you are trying to send from Logic unless the 2880 receives SPDIF digital audio with accompanying clock and locator signals.

    These settings will allow Logic to send MIDI to an external computer, trigger audio on it, and sync it back into Logic for recording. I use wordclock and LTC to sync two computers, and the audio stream coming back to Logic is ADAT. Different than what you are doing...
     
  6. pv_joker

    pv_joker Member

    Thank you JuanTahnahmahrah for all your help. I've managed to sort the problem, believe it or not I just updated the midi drivers for my Motu and all was well.

    I managed to accomplish this about 5 minutes before rehearsal last night so, as you can imagine, I was very popular! I really can't wait for the gig now, such a weight off my shoulders.
     

Share This Page