1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 problems with upgrade 8 to 9

Discussion in 'Logic 9' started by jon leadbeater, Dec 22, 2009.

  1. jon leadbeater

    jon leadbeater New Member

    oh dear! had a lovely, reliable studio set up, with macbook, apogee ensemble and logic 8......then upgraded to 9 and chaos; loads of issues with the following message

    "Error while trying to synchronize Audio and MIDI.Check conflict between Logic Pro and external device"

    worse still, the same projects that ran with pretty minimal cpu load in logic 8 now cause the cpu's to max out even before pressing play!

    Have spoken to apple support, who are very nice, but the upshot is that the only recommendation was to completely wipe the hard drive in a system restore and go back to logic 8......not at all chuffed and now in a fix cos this week was recording session with harpist
  3. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    The "error while trying to synchronize..." message can possibly be cured in the sync window. But the CPU load sounds like you may not have a fast enough CPU or enough memory. What are the specs for your laptop?
  4. Colin Shapiro

    Colin Shapiro Senior member

    In my experience, advice to wipe a drive and start afresh is typical of those who don't have the right answers.

    As Juan said above, check your sync settings. Also, go to your Audio prefs and make sure you have the correct outputs selected (ie the correct device).

    Do you have lots of EXS24 instruments in your songs? Check the EXS24 prefs and try different options.

    Having said all that, Logic 9 does seem to hit your CPU's harder than Logic 8.....
  5. jon leadbeater

    jon leadbeater New Member

    Thanks Juan! my macbook is 2.4 g intel core2 duo with 4gig of ram. I know it isn't the fastest mac, but the difference between projects before (in logic8) and the same project in 9 is huge....in 8 minimal cpu in 9 both maxing out in the red, even a relatively simple recording. I use logic to record acoustic instruments, tabla, harp and voice mostly, so no heavy synths or plugins to make the load heavy.
    So.....I found the sync window and changed the settings in audio to MTC trigger + auto speed detection from just MTC trigger. The result is that my projects now play perfectly with only minimal cpu load, fantastic, thanks Juan
  6. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    That's got to be gratifying, especially after the faux pas from Apple's support. I was hoping you would figure it out, because my setup is different that what you have. So, now that you upgraded, tell us all if there is a noticeable difference in Logic 9's operation, speedwise, relative to 8. I still have to make the upgrade myself, and am curious. Also, for reference, what were the sync settings that were bogging down your system? Did you have to change any master/slave clock settings on the Ensemble?
  7. jon leadbeater

    jon leadbeater New Member

    well, still seems to be back to nice + reliable, I'm now not noticing any extra load on the cpu, if anything 9 seems to pull less....the sync settings were simply the audio ones, and I just selected the option to include 'auto speed detection', which wasn't selected before.
    The ensemble just worked, no need to change any clock settings either.
    I'm loving the new reverb choices, for tabla and percussion they are great, as regards the rest.....I'm still doing simple recordings and basic mixes, but so far its' great

Share This Page