1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Project file saving extraneous audio files outside the package

Discussion in 'Logic Pro X' started by canalstreet1, Sep 20, 2015.

  1. canalstreet1

    canalstreet1 New Member

    Logic ProX v 10.1
    New Mac running Yosemite.

    I have a project file that is acting abnormally.
    When I iterate up and save the file it saves a bunch of unrelated audio files inside the project folder but outside the package ( I like to save to packages)
    They seem to be related to another project ( different song)
    I've collected and deleted all unused files. Don't see any latent regions from any other song.
    But Still get a promp about missing audio files when I load the project.
    Skipping all does not result in any missing files in the project. ( they are not needed).
    This is a new problem.
    Brand new computer, running flawlessly up till this event.
    To recap...
    The project file loads fine, but I get the missing file prompt. I skip all and all track and clips are normal.
    I would guess there is something in the project linking to a different project file but danged if I can find it.
     
  2.  
  3. Eli

    Eli Senior member

    Your post is slightly confusing. You talk about having both a project folder and a package. How do you have both connected with a single project?

    In any case, I'm pretty sure the source of your problem is that you have audio files that are in your project audio bin that are not used I the Tracks Area. So, open your browser section, click on the project audio tab, and delete references to audio files that are not used in your project. Then resave, and all should be fine.
     
  4. canalstreet1

    canalstreet1 New Member

    Hi Eli, thanks.
    To clarify.
    I save my logic project files (packages)In folders for each song
    I save redundant files as I iterate up working toward a final.
    I'm aware that creates redundant audio files but I prefer to do it that way, safer.
    Never lost anything in 100s of projects.

    Yep I have done what you suggest multiple times , problem persists.
    As you know there is a command to show file in finder.
    Is there a way to do a reveal file in project command so I can see where they might be hiding?
     
  5. canalstreet1

    canalstreet1 New Member

    Ok, so I have half the problem worked out.
    I found a file hiding in the browser that didn't belong there (Sometimes I use an earlier project as a start-up template, I bet that's where it came from)
    Once I trashed the stowaway file the proj. loads fine.
    Typically, as I get close to final I start tidying things up - Select and trash unused files, in this case the operation simply didn't see the file ???
    Soo...
    Now i still have the remaining half of the issue.
    I save the proj. as a package and that works as normal, but recently recorded files are saved outside the package into my main folder.
    have I inadvertently assigned a path outside the package to specific regions or tracks?
    Thanks
     

    Attached Files:

Share This Page