1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 random, unwanted midi transpose/pitch shift issue

Discussion in 'Logic 9' started by jimmydeluxe, Mar 14, 2010.

  1. jimmydeluxe

    jimmydeluxe Member

    Hi,

    I think this has only happened since the 9.2 update. During playback, a midi instrument--EXS or third party (Korg, etc.) will randomly shift up a half step and continue playing up a half step. No settings change on the instrument, and if I wait a while and restart playback, it will sometimes go back to normal. Anyone else have this? I searched quite a bit...

    Ok, now I'm not sure if it's only the Korg Polysix. I restarted the project and it (Korg PS) still had to be pitched up 3.60 to match the other instruments (no transpose settings on any channels), but the exs is not changing. This was working fine, of course, when I started the project yesterday.

    Any help appreciated!:brkwl:

    OK--update: appears to be something going on with my remote 61 sl. While recording a part (same song, different synth plug) it transposed the keyboard up again. When I moved the pitch bend joystick, it changed again (and stayed). Think I'll see if there's an update for this controller--tried removing and adding...
     
  2.  
  3. David51

    David51 Senior member

    random, unwanted midi transpose/pitch shift issuerandom, unwanted midi transpose/pitc

    Thank you Mark, I am confused by the options available in the e-mail newspetter but will from now on go to this link to send a reply or Post a new one, I feared I had sent this reply to a Yahoo windcontroller group-but you have received it so I did at least have the correct forum:D
    Hi, I had that problem from the beginning in Logic Pro 9-the only workaround I found was to lock the MIDI tracks-that means constantly having to lock and unlock tracks but in the end it was easier than trying to restore the MIDI file that had morphed into something else-mind you, I am talking about the track protect function not the freeze-they can be added or removed by customizing the track headers-but that function seems to not always work-the next time I open the Project the Track headers have reset themselves on their own-is that a common bug?
     
  4. jimmydeluxe

    jimmydeluxe Member

    I could try that, but it's happening while I'm playing--before I've committed to a take. Thanks for the idea, and yes--track headers always reset themselves over here, too--I took it for granted that that's how it was, haha--funny how I just tolerate bugs!
     
  5. David51

    David51 Senior member

    Sorry to read that the transpositions are happening while playing, I haven't had that [yet]. I can't think of anything to say that might help-time for the real Pros here to kick in, also shared schadenfreude for me to hear from a user whose track headers also revert to something else-even when using locked screen sets[just out of curiosity-NO it happens when playing-or yes can you play and record with the screen set locked?
     
  6. jimmydeluxe

    jimmydeluxe Member

    It happened while recording or playing back (pitch). The headers, I thought that's just how Logic was, always resetting stuff like that and the play bar (capture take button has to be re-added every time I open a project). I never tried locking the screen set.

    Ok, some relief here--I erased the novation out of control surfaces, reinstalled and changed the port--it was on 2 for some reason, I changed it to 1. It worked last night w/o changing pitch, hopefully it sticks!
     
  7. Colin Shapiro

    Colin Shapiro Senior member

    Are you using SoundDiver by some chance?

    There is an old bug with SD beta for OSX that causes random transpose problems in Logic if the 2 apps are open at once.

    Just a thought.......
     
  8. jimmydeluxe

    jimmydeluxe Member

    Thanks for the reply. No SoundDiver.

    Still had the issue on an old project where the pitch had already shifted (on Korg softsynth), but no trouble on new projects so far after switching the port and reinstalling in control surfaces...
     
  9. Lincoln M

    Lincoln M Member

    Not sure if this is the same issue, but I'm experiencing something similar. Moving a midi region in the Arrange window causes transposition - randomly. Meaning only some notes transpose. Rhythms are unaffected.

    Anyone else's experience would be appreciated.
     
  10. jimmydeluxe

    jimmydeluxe Member

    It's doing it again. I'll be recording a take and the softsynth will transpose up a key. This sucks--Logic is no longer a pro app in my book--it's become unstable, crashing without save 5 or more times a day, and full of show-stopping bugs. Had a session with a client last night and had the not enough memory to continue bug and had to restart twice. Jesus, it's like having Cubase 4 with a pc again :brkwl:

    Does snow leopard at least help with ram issues? I've read some places that it does, some that it doesn't. I like some of the new features, but I'd trade them ALL for the stability I first experienced with 8. Logic Pro is becoming more and more Logic Prosumer/Garageband Pro with every update. I take that back, I think 9 was much more stable for me than 9.1...

    Maybe I should start working in Garageband, or PT 8.

    Sorry for the rant, but this is beginning to get to me--obviously.
     
  11. Lincoln M

    Lincoln M Member

    I don't exactly know why this was happening to me, but, what I did was start a new session, and import all of the tracks from the other and I've not had the problem since....

    As for Logic being Garage Band Pro or PT8 - All DAWs have issues. All. Hang out on the DUC for a minute and see what most of the users there are talking about and you'll be happy.

    Most all of my problems - with any DAW, have been user/system. Yes bugs exist, but at least Logic has been coming out with frequent fixes.

    Sorry your havin' a rough time...
     
  12. jimmydeluxe

    jimmydeluxe Member

    You are right, the updates have been surprisingly frequent. I know all apps have issues, but the fact that I just opened a project I did two years ago that had 20 synths and 24 audio tracks (non-frozen) with tons of plugs with no problem, and trying to do that today would never happen with the current, "low-memory," bug, is bogus.

    However, I will say I'm grateful that there is 9.1.1, and it seems to be running better already, though the "low-memory," shutdown bug persists, on a new project with 9 synths, 10 audio tracks, and less plugins than the above mentioned, two year-old project. I've been mixing, not recording, so I hope the transpose bug is gone for good.
     
  13. jimmydeluxe

    jimmydeluxe Member

    Did the transpose thing again during playback/mixing:mad:
     

Share This Page