Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Reconstituting missing EXS samples via internet

Discussion in 'Logic 9' started by chalkncheese, May 27, 2013.

  1. chalkncheese

    chalkncheese Member

    I have recently lost some samples in between geographical moves and mac migrations; the key samples I am missing at the moment that I need are saxes, flutes and oboe, although I expect I may find more. I am currently overseas and dont have my set of Logic disks with me, so is there a way to download L9 samples via web?
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

    Yes, provided you are running Logic 9.1.6 or newer.

    Go to Logic Pro -> Download additional content. This opens a dialogue window showing an overview of the content installed on your system. It should also highlight what is missing, and suggest you let it D/L and install whatever that might be.

    kind regards

    Mark
     
  4. chalkncheese

    chalkncheese Member

    Thanks Mark
     
  5. chalkncheese

    chalkncheese Member

    ...sorry, pressed the wrong button there... What you advise sounds like it will show up which files are missing, but where can i get the actual samples, i do not have the disks with me and i think they may themselves be defective anyway as i experienced missing samples even before reinstalling Logic. I ask because i am sure i read somewhere one can reconstitute the sample library via the web. Am i right?
     
  6. Markdvc

    Markdvc Administrator Staff Member

    Why not just let the Download additional content menu do it's thing? Once it is through you should have all the logic content installed on your system and ready to be used in Logic. I am not aware of any other method to obtain content, apart of course from reverting to the install discs that came with Logic Studio II.

    If for some reason, neither of these options are possible (and/or your discs are damaged), you need to contact Apple care.

    kind regards

    Mark
     
  7. chalkncheese

    chalkncheese Member

    Didn't even know it did that. Mark thanks, nagging problem sorted.
     
  8. Eli

    Eli Senior member

    Hey Marc,

    Just curious: Are you saying it is possible to download Logic Pro content even if you didn't purchase Logic through the Apple Store originally? i.e.: If you purchased it the old fashioned way - as an upgrade from Logic 8 way back when, on DVDs?
     
  9. Markdvc

    Markdvc Administrator Staff Member

    Hi Eli

    My experience was, after updating to Logic PRo 9.1.6, the first App store version, on first starting it, it informed me that some content was missing. I then let it D/L and install what it said was missing. Needless to say, I upgraded to 9 from 8, 7, 6, 5 etc etc

    The down side is of course that it wants to have content on the system drive. Not a good development IMO, I would really prefer Apple to change it back to allowing us to put content where it suits - in my case, a dedicated internal drive in my Mac Pro.

    kind regards

    Mark
     
  10. Eli

    Eli Senior member

    I only recently upgraded to Mountain Lion and Logic 9.1.8. I was on OS 10.6.8 and 9.1.5 untill a few weeks ago - I was one of the unlucky few who had the performance lag problems at startup with 10.6.8 and higher Logic versions.

    I'll have to check out the software download options and learn how it all works. Too bad about the location restrictions:-(
     
  11. chalkncheese

    chalkncheese Member

    Spoke too soon, I tried this and in spite of the Additional Content page telling me all packages had been 'installed' when I went to Application Support / Logic / ESX Factory Samples it was immediately clear that many of the samples were missing; for example Acoustic Pianos should have Classical Grand Piano, Grand Piano and Bass, Grand Piano and Pad etc etc and finally Yamaha Piano - yet the only instrument showing in my Finder is Yamaha Piano .. I took a screen grab showing what Logic Additional Content says I have installed and what Finder actually has installed but I can't attach it.

    Anyway, it seems I still have the problem, has anyone else tried this and perhaps experienced the same?
     

Share This Page