Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Record two tracks simultaneously from one source

Discussion in 'Logic Pro X' started by Voice Man, Oct 1, 2015.

  1. Voice Man

    Voice Man Member

    Hi,
    You guys have come through for me in the past, I'm hoping you can solve this one for me.

    Equipment:
    MacBook Pro (17in late 2011), Yosemite 10.10.5 OS.
    Signal Chain: Sennheiser 416 > Golden Age Pre 73 > Crate SM4CL Compressor > Duet Maestro > Logic Pro X.

    Here’s the situation: I want to record a video conversation over Skype on Logic Pro X that allows me to record the ongoing conversation on two tracks simultaneously. Track A is for recording the whole conversation to review at a later date. Track B needs to enable me to find and play back a section for review by both parties during the session, and importantly, allow the playback to be heard over Skype by the person on the other end.

    I’ve spent hours trying to figure out how to set up two tracks to record simultaneously from one source. It appears I needed to set up an aux channel strip to act as a bus to send the signal from track A to track B. I’ve read Ira’s LUG post “How to create a BUS channel to route multiple channels to?” I tried setting that up, and discovered that right clicking on the aux send created an aux track. Cool. I hit record on the track (Audio 1) that’s bussing to the aux track. Audio 1 records, but the aux track doesn’t. So I tried sending it to Audio 2. Armed record there, too, but it won’t record there either. I can’t figure out why.
    If someone has a clear way of helping me figure this out I’d be grateful. Or, is there a better idea?

    The second piece of this puzzle is the signal feed. I got Soundflowerbed, and I’ve set up an Aggregate Device that contains Duet and Soundflower 2ch. It seems I can set up Skype preferences to recognize the Aggregate. I know to set Logic audio prefs to recognize the Aggregate. Does this set up seem correct?

    Background: I ran a Skype session using Audio Hijack and LPX but I had problems. Hijack converts the audio to an mp3 and it’s a hassle to shuffle around it to find the section to play back during the session. I know Logic would allow me to set markers for playback reference (I just don’t know how to do that yet). Playback was over my studio speakers, picked up by my mic, and faintly heard by the other party via Skype. Embarrassing. That’s why I got Soundflower.

    Thanks!
    Voice Man
     
  2.  
  3. EdgarRothermich

    EdgarRothermich Senior member

    You can't record audio on a Track assigned to an Aux Channel Strip!
    You can only record audio on a Track assigned to an Audio Channel Strip. The trick is to use the Sends to route the audio signal to a Bus. Now when you create additional Audio Tracks, you choose those Busses from the Input Button on the Audio Channel Strip instead of one of the Input Busses.

    Audio Track 1:
    On the Input, select the audio source (Audio Interface)
    Select Input Monitoring to "open" the input
    You can use FX processing that affects both Sends if needed
    Use the first Send to route to Bus 1
    Use the second Send to route to Bus 2

    Audio Track 2
    Set Input to Bus 1
    Record Enable to record that signal

    Audio Track 3
    Set Input to Bus 2
    Record Enable to record that signal

    For monitoring you have multiple options. Either you turn down the Volume Fader on Track 1 (Set Sends to Pre Fader, you can't use the Mute, because the Sends are after the Mute Button) and monitor on the Audio 2 and Audio 3, or keep the Audio 1 Fader up and Mute the Audio 2 and Audio 3
     
  4. Voice Man

    Voice Man Member

    Hi Edgar,
    First let me thank you for going to the trouble to lay this out for me. Much appreciated.

    I set up everything as you suggested, but I must be doing something wrong. There is no signal going into Audio 1 or 2. I noticed that when I open the input on Audio Track 1 and try to select the Audio Source (Audio Interface) there isn't a designation "Audio Interface." The only choices are Input 1 (Line 1), or Input 2 (Line 2) -- Unless these are indeed the Audio Interface choices. I chose Line 1. I can arm both tracks, but as I said, nothing records on Audio Track 2. Choosing Bus 1 didn't make any difference other than allowing only one track to be armed. I've played with some other configurations but no success. I've included a screen shot of the set up. Maybe you can see something I'm doing wrong.

    Once again, thanks for your help. Voice Man
     

    Attached Files:

  5. EdgarRothermich

    EdgarRothermich Senior member

    On your screenshot, look at the Input Monitoring Button of Audio 2. On the Channel Strip is looks like it is enabled, but look at the Track Header, you see that it has a different appearance. That indicates that you have a special checkbox enabled:
    Preferences ➤ Audio ➤ General ➤ "Input monitoring only for focused track, and record-enabled tracks"

    This is a very "nasty" checkbox that messes up your routing and conditions, just plain confusing. Unfortunately it is enabled by default, but you should disable it right away. That should put your Channel Strips that have Input Monitoring enabled into Input Monitoring Mode.

    One other thing about the screenshot. You are double processing your signals if you have FX Plugins on the incoming Audio Channel Strip and also on the Channel Strip that you route that signal to. Choose one depending what you want to process
     
  6. Voice Man

    Voice Man Member

    Hi Edgar,
    I disabled "Input monitoring only for focused track, and record-enabled tracks" and changed the FX pug ins on Audio 1 and 2. Still the same result. No signal into Audio 2. Can't record. I've included a screenshot of this update and the prefs panel. I'll keep at this.

    Thanks again,
    Voice Man
     

    Attached Files:

  7. EdgarRothermich

    EdgarRothermich Senior member

    Software Monitoring has to be enabled in the Audio Preferences
     
  8. Voice Man

    Voice Man Member

    OMG. That did it. However, the volume in Audio 2 is very low. I've tried increasing the fader in Audio 1 but that didn't do anything. There must be something obvious I'm overlooking that will create the same level in both channels.
     
  9. EdgarRothermich

    EdgarRothermich Senior member

    You have to turn up the Sends Knobs. Option+click to set them to Unity Gain 0dB.
     
  10. Voice Man

    Voice Man Member

    Okay, I tried option +click on the sends knobs for bus 1 and bus 2 on the Audio 1 channel strip but that didn't set them to Unity Gain 0dB. I didn't see anything that said that. So I manually turned them up to +6.0, which helped a little. But Audio 2 still doesn't have the presence of 1.
     
  11. EdgarRothermich

    EdgarRothermich Senior member

    The ctr+click on the Send Knob (not the button) should work.

    Here is an example how your setup should look like:

    Audio 1: I simulate the input signal with the test oscillator Plugin feeding a 0dB audio signal. Both Sends are set to 0dB as Post-Fader Sends. That lets me control the signal I'm recording on Audio 2 and Audio 3 with the Fader on Audio 1. I set the Volume Fader on Audio 1 to -6dB (see the Volume Display) and that is the signal that is sent to Audio 2 and Audio 3 via the Sends. I use Pre-Fader so I can see the signal before the Fader. It shows the exact 0dB that is coming from the Osc.
    Audio 2 is receiving the -6dB signal via Bus 1 and it reads it properly on its Volume Display and the Volume Meter
    Audio 3 is also receiving the -6dB signal via Bus 2 and it reads it properly on its Volume Display and the Volume Meter

    Stereo Out: Note that I set the Output on Audio 1 to "No Out", so it doesn't go to the Output Bus. the Output Bus is only receiving its signal from Audio 2 and Audio 3. Both sending -6dB, so "(-6db) + (-6dB) = 0dB". Everything works properly

    Audio 2 and Audio 3 are Record Enabled, so when I hit record, I record the same signal coming in on Audio 1 to those two Audio Tracks.


    [​IMG]
     
  12. Voice Man

    Voice Man Member

    Hi Edgar,
    Thanks for being patient with me, this is all a bit over my head.

    I’ve spent more time on Logic Pro X Help but I still need your help.

    First, I think I got the sends knobs on Bus 1 and Bus 2 set to 0dB. At least they look the same as on your screen shot. (I did this by holding down the mouse and using the knob like a slider.)

    Now, as far as “simulating the input signal with the test oscillator Plugin feeding a 0dB audio signal.” Here’s a screen shot of what I’ve done. I set the level slider to 0dB but the noise level is screaming loud. (the factory setting is -12dB) I must be doing something wrong. There’s a dropdown menu from the Factory Default bar that has many settings. Is that the place to make this setting? Could you please send me a screen shot of how the Test Oscillator is supposed to look?

    I believe I’ve set Bus 1 and 2 as Post Fader sends.

    I’ve included another screen shot of the set-up. I think it’s correct.

    Finally, you said that you use Pre-Fader so you can see the signal before the Fader. “It shows the exact 0dB that is coming from the Osc.” I’m not sure what or where this is. In the Inspector for Audio 1 it displays Freeze Mode: Pre Fader. Does that mean that the Pre Fader is correctly activated? Do I need to be able to control it?

    I believe I’m inches from getting this all set up correctly. I appreciate all you’ve done for me so far.

    -- Voice Man
     

    Attached Files:

  13. EdgarRothermich

    EdgarRothermich Senior member

    First of all, ignore the "Freeze Mode: Pre Fader", different topic different conversation. It has nothing to do with your setup.

    You Osc Plugin is correct. Yes, 0dB sine waves can be ear-piercing so turn down the speakers. Remember, this is just for test purposes to better follow the signal flow.

    In your setup. Delete the Aux Channel Strips. You don't need them and you just amplifying the signal.

    You can toggle Pre-Fader Metering with its separate Button on the Control Bar or use the Menu Command "Mix ➤ Pre-Fadr Metering"

    Make sure to Record-Enable Audio 2 and Audio 3. otherwise, Logic will record on the selected Track.

    Everything else looks fine.
     
  14. Voice Man

    Voice Man Member

    Hi,
    I shut down the Test Osc to eliminate the sine noise. I inadvertently deleted Audio 1 when I tried to delete the aux channel, so I rebuilt it -- hopefully I put back together ok. (Found that using delete on the keyboard deletes the aux) Ran a recording test and immediately experienced feedback thru the headphones (in my booth) and the exterior speakers. Yikes! never had this happen before. I checked the audio prefs and everything seems normal. Turned off the speakers in Duet but still feedback in the headphones. Ran another test over a different template I use for auditions and feedback as well. Do you have any idea what might be causing this? My mic is in an isolation booth.

    Sorry to be such a problem but I'm so close to having all this work!
     
  15. Voice Man

    Voice Man Member

    Hi,
    Dealing with acoustics and Duet to get rid of the feedback. Might have it solved so I ran another test recording and everything works fine except that Audio 2 and 3 both record at the same low level, which was one of the original problems we experienced. Their wave forms are much reduced compared to Audio 1. If I can get the record and playback levels up to strength, I'll be on my way.
     
  16. Voice Man

    Voice Man Member

    Thanks Edgar! I've got this thing going. In the process I got a good education about some aspects of Logic that I didn't know about. Onward!
     
  17. EdgarRothermich

    EdgarRothermich Senior member

    Good to hear that it works.
    If you need more good education and learn more aspects about Logic that you might not know yet, I can recommend the Logic books in my Graphically Enhanced Manuals series. http://DIngDingMusic.com/Manuals
    They are also available as interactive multi-touch iBooks on the Apple iTunes Store. These are the only true interactive learning books for Logic. All the Logic terms are active links throughout the content of the book and when you tap on it, it opens a popover window with the explanation (with graphics and further links). You can download free Sample Books to try it out.

    [​IMG]

    BTW, these books are the only ones that are up to date with he current Logic version 10.2. So you don't have the frustration when trying to lean a software with an outdated book or YouTube videos.

    Thanks
     

Share This Page