1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Reindex Logic Instrument content?

Discussion in 'Logic 8' started by thirdspace, Apr 2, 2009.

  1. thirdspace

    thirdspace New Member


    For some reason when I click on instruments in the Channel Strip Settings I get this message:

    EXS Instrument "Example.exs":
    Audio file "example audio file with a long name.aif" not found!

    Running a spotlight search reveals that these files do not exist on the computer. It's highly likely that I have screwed things up as follows:

    I previously had GarageBand V1-4 and Logic content moved to an external drive (including instruments) which worked fine but was awkward. I then decided to have the Logic content back on the internal disk so have installed it (the content only) from the DVDs, and have installed GarageBand 5 (iLife 09) but not all the earlier versions. Perhaps these missing instruments belong to GB V1-4, in which case why does this message affect so many of them?

    Is there a way for Logic to reindex its instruments/instrument samples (Like it can with the loops)? There is no problem with missing loops.

    Or should I reinstall Logic - in which case should I uninstall first, and if so what is the best way?

    And should I reinstall GarageBand V1-4 (if I still have the disks)?

    Is there a definitive guide as to which program provides which content, and how to make it available to both GB and Logic?

    Sorry - that's a lot of versions of the same question!
  3. Eli

    Eli Senior member

  4. thirdspace

    thirdspace New Member

    well, thanks for the suggestion, but is there not a way to do this without spending money?
  5. Eli

    Eli Senior member

    Not that I can think of- other than re-installing everything.
  6. Colin Shapiro

    Colin Shapiro Senior member

    If you still have an older version of Logic eg v7.x you can use Logic's Project Manager to re-link your EXS instruments. Go to [Windows] menu & select [Project Manager]. You'll need to look up the manual how to run it properly.

    The Redmatica app is about a thousand times faster though (really) and more efficient - well worth the price if you can afford it.
  7. thirdspace

    thirdspace New Member

    Thanks again for the replies. Now that you mention Logic 7, it is no longer on my system, but used to be. Is it possible that these instruments belong to Logic 7? An example is Cavern Kit in Acoustic Drum Kits. If not, where has that come from?

    Does anyone know of a definitive list of what instruments install with which versions?

    No relinking of instruments without Redmatica or Logic 7 then?
  8. Colin Shapiro

    Colin Shapiro Senior member

    Cavern kit is a factory file from Logic 8 as far as I know.

    The thing about re-linking EXS instruments is this:
    When they are packaged and shipped to you, all the references inside the EXS instrument files point to samples on a drive that someone else owned. (ie the file paths are "foreign" to your system). When you load that instrument, Logic has to search for all the samples and loading can be very slow or even unsuccessful.

    Re-linking re-writes all the file paths to refer to the actual samples on your system, with the result that loading EXS instruments is immediate. (much better for workflow....)

    So, you could re-install Logic 7 but better by far is EXSManager by Redmatica, particularly if you have lots of 3rd party libraries of instruments. EXSManager is far more efficient than Logic's Project Manager ever was.

    Hope this helps.....
  9. I think re-assigning the sample paths isn't the problem here - I mean, thirdspace mentioned the EXS complaining about audio files not being found. And no re-assigning tool on the world would help with that.

    I suspect the Logic 8 installer to be the culprit here. It sometimes simply doesn't install all the content. This is a very wellknown problem. Just a while ago I've been teaching a Logic workshop at the local music university, and there's been 6 student machines, all of them had a full Logic installation on them, but believe it or not, not a single EXS instrument and channel strip preset folder looked the same!
    Personally, I experienced a similar problem. On my old Macbook, apparently everything (well, who knows...) was installed, not so on my new Macbook. But it's not as if the installer stopped, complained or did anything. It finished just normal. A while after the new install I noticed some less channel strip presets and missing Ultrabeat samples. Now, fortunately I still had the old MBs drive, so I simply copied them from there.

    Having said all that, I can only recommend repeating the content installation (and don't delete anything before). This helped some people.
    I would also recommend repairing disk permissions before doing so. And I would probably even run a few of the system maintainance tools Onyx offers (Onyx is free and excellent), so your system is as "prepared" as it gets when you repeat the installation.

    Fwiw, I found the EXS' sample search function under Logic 8 to be massively improved when I had to re-link a bunch of sample sets.

    Oh, another thing coming to my mind: Before you do any of the described, check whether the EXS is allowed to search on your internal drive. You'll find a preference for that in the EXS' option pulldown. As you mentioned you've had your samples on an external drive before, have you done something to this preference?

  10. Colin Shapiro

    Colin Shapiro Senior member

    Actually, EXSManager did help me. I had quite a few Logic factory instruments that were "incomplete" and after doing some re-linking, all the samples were eventually found and the insts were complete.

    Seems the Logic installation has several files without .aif or .wav extensions and this somehow prevented them from being found, amongst other problems.
  11. Yeah, might be. Seriously, the Logic 8 installer is far from being professional at all. As said, I've seen several incomplete installations (including one on my own machine), but the installer apparently doesn't properly check the files it has to install, nor does it complain about a disk probably being unreadable or whatsoever. It just runs through and often seems to leave out some things (one of the mentioned student machines didn't even have half of the delivered content).

    - Sascha
  12. rainguitar

    rainguitar Member

    Hi Sascha,

    I'm not sure if this is related to the old "missing content" issue or not. If you're on a newer mac and have iLife 08, load Garageband, select a software instrument track and choose drum kits. You'll find the "Pop Kit" grayed out with a little arrow beside it. Click on this and Garageband will ask you if you want to download I believe they call it extra content. There's actually quite a bit of stuff missing so if you click on this you'll get all the missing stuff that Logic overwrites on installation. Takes a while to download though.
  13. PKGuy323

    PKGuy323 New Member

    As a thread revival, I ran into this with Logic Studio 9. I reformatted and reinstalled everything.

    What solved it for me was re-installing GarageBand and letting it download all the "additional" content. I thought those files would be included in the LOGIC install but I guess not. Once it downloaded the additional content, my Logic Files all worked and found those EXS files.
  14. rainguitar

    rainguitar Member

    Interesting, I never ran into this problem with Logic 9, only with 8. I wonder what's going on here.

Share This Page