Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Return Key, Takes me to beginning, but play begins elsewhere

Discussion in 'Logic 8' started by 2oh1, Oct 1, 2009.

  1. 2oh1

    2oh1 New Member

    Hi all! I'm new to Logic after 15 years of using Pro Tools (I should have made the switch years ago), so please bear with me. I'm struggling a bit with getting Logic to play in a way that seems logical to me.

    I have my right mouse button set to Marquee Tool. Let's say I right-click in the arrange window at 0:05 into a 30 second piece I'm creating.

    When I press the spacebar, I want Logic to play from there (0:05). When I press the spacebar again, I want Logic to Stop and return me to 0:05.

    In Key Commands, I have my spacebar set to Play or Stop and Go To Last, and it works.

    Here's the problem:

    When I press RETURN, Logic takes me to 0:00 (I have return set to "Go To Beginning" in key commands). Again, this works. Ah, but when I press my spacebar, Logic plays from 0:05 rather than from 0:00. NO!!!

    How do I change this? Is there a setting somewhere else that's conflicting with my spacebar and return key functions?

    I'm using Logic Pro 8.
     
  2.  
  3. Eli

    Eli Senior member

    This is probably because you have that single pixel marquee stripe still active in your arrange window. When you do a short click with the marquee tool, logic will play from this position regardless of where the playhead is situated. The way to get rid of this behavior is to just click in the background with the pointer tool to "de-activate" that tiny single pixel marquee stripe (that's not exactly the right term for it - I'm just trying to describe it for you)
     
  4. 2oh1

    2oh1 New Member

    Ah-ha. And this is the case. That's kind of annoying. Is there a way to have the return key change the location of that marquee stripe to 'beginning' and also have it go to beginning?
     
  5. ibt

    ibt New Member

    Right click on the Play button for a few more options btw
     
  6. Doug Zangar

    Doug Zangar Senior member

    Don't think you can do that. As Eli mentioned, click in the background to get rid of it is your best plan.
     
  7. Eli

    Eli Senior member

    The only other choice you have is to disable the functionality of having the playhead snap to the position of the marquee stripe when you hit play. You can do this from right clicking on the play button and checking that behavior off.
     
  8. 2oh1

    2oh1 New Member

    The only thing I get when I right-click on the play button is an option to "customize transport bar".

    Am I missing something here?
     
  9. Eli

    Eli Senior member

    I think it's only in Logic 9 that they introduced the customizable play and stop behavior.
     

Share This Page