1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Sample accurate recording..

Discussion in 'Logic 8' started by DSP Hungry, Apr 23, 2009.

  1. DSP Hungry

    DSP Hungry Member

    I recently moved my studio to a new location and have been performing some tests before recording a big project.

    I am noticing a sizable delay when recording to Logic from my external MIDI
    gear.

    It looks like Logic is capturing the audio about 200 samples before it should
    be? I would not like to have to offset audio or MIDI recordings in the settings
    pages if possible. Any thoughts out there? :eeek:
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

    Can you describe your set up in detail, in particular, if you have latency compensation set to all, and if you are using any latency inducing plugins in Logic's outputs?

    kind regards

    Mark
     
  4. DSP Hungry

    DSP Hungry Member

    I am running Logic 7.2.3 with a Unitor 8, an MT4 midi interface for my Mackie control.
    2 Motu 828MK II interfaces synced via IE3994 with modified clocks.. (could be the issue)

    I could adjust the MIDI delay in he preferences?
     
  5. DSP Hungry

    DSP Hungry Member

    Yes.. ALL and no plugs in test session.
     
  6. HKC

    HKC Senior member

    That´s the problem. You can´t use the "all" setting with external midi unless you run the external midi into Logic through inputs or the "external" plugin. Off-setting doesn´t help because it will change with every plugin you add.
    Running the outboard synths into Logic takes a lot of inputs (if you have a lot of midi'ing going on) but it does work.
    The way most work is to use the channel and instrument compensation setting (under latency compensation) and avoid using the busses until you´re done recording. At that point it may be simpler to just record the outboard midi as audiotracks. It also solves the problem if the synth at some point get sold or breaks down and you won´t have to worry about the delay compensation.

    PS you can use busses for things like reverb, delay, chorus etc. Not because they are compensated for but because it´s a lot less noticable if it´s slightly out of time.
     
  7. DSP Hungry

    DSP Hungry Member

    PDC..

    I'll try it and let you know! Thanks!:thmbup:
     
  8. DSP Hungry

    DSP Hungry Member

    LINE ME UP...

    OK... Here is my issue.

    I have tested my system with PDC set to off / audio/inst and ALL and get the same results.

    When I track my external MIDI gear into Logic through my MOTU 828's the
    audio appears to be 17 ticks early or ahead of the bar? :errr:
     
  9. LivePsy

    LivePsy Member

    External midi instruments out of time is perfectly normal. You must compensate for each instrument in its instrument settings. Please consider that you can never achieve sample accuracy, the midi gear will respond differently on each note on.

    This is why a DAW will give you superior results to a hardware midi sequencer: you can compensate for every piece of equipment and get notes on time. Its not a fault in your setup, its your chance to get everything in time. You are just noticing the timing errors for the first time.

    I've found that once you find the right delay compensation for each external midi device, it is the right setting in every project. So do the tests once and everything is fine after that.

    Regards,
    B
     
  10. DSP Hungry

    DSP Hungry Member

    psy

    Ok.. Instrument settings in the parameters window (delay)? Do you measure in ticks or samples?
     
  11. LivePsy

    LivePsy Member

    Doesn't really matter in what units the delay is shown. Create an external midi test track containing quarter notes on every beat. Record the audio from the external midi instrument and open the sample editor on the audio. You'll see how much you have to bring the midi forward (negative delay value). Note that your choices are ticks or milliseconds for the external midi instrument. Just try a negative delay, 10ms is quite normal. Rerecord the audio and have a look at the result. Scroll through the audio and check a few quarter notes and you will see they don't all happen at the same point each quarter note. Just pick a negative delay so that most of the notes are where you want them.

    Find the delay value which compensates for each midi gear you have and keep it in the instrument object. You still have the opportunity to change the delay in individual midi regions if you want to change the feel. Just be aware of which delay setting you are changing.

    Failing to do this procedure can lead to disappointing results in your work because the instruments are just not playing in time. Please also check that the relevent midi and audio delay settings in preferences are both on 0.

    Regards,
    B
     
  12. DSP Hungry

    DSP Hungry Member

    B

    great.. finally someone understands my issue! I'll give it a go tomorrow..


    Cheers- :thmbup:
     
  13. DSP Hungry

    DSP Hungry Member

    score!

    Thanks psy.. I found that a delay of about 40 or 1/96 note gets my AKAI
    S5000 all lined up! :thmbup:
     
  14. LivePsy

    LivePsy Member

    Good for you, DSP. And now the recordings sound right, I bet.

    Cheers,
    B
     

Share This Page