1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Sample editor issue and Flex time with tempo shifts is pretty tough.

Discussion in 'Logic 9' started by georgelegeriii, Jan 2, 2010.

  1. georgelegeriii

    georgelegeriii Senior member

    Hi Luggers, I have 2 observations and a question:

    1) In the sample editor, the prelisten function works using the space bar. So, if you are playing you mix from the arrange page, and open or have open the sample editor, using the space bar to start and stop your mix is a nightmare. You hear the selection of audio that is in your sample editor, as well as the main arrange audio... seems like a pretty bad choice on Apples part.

    Now a normal fix for this would be to assign the prelisten in the sample editor to another key command... if it were in the sample editor key command available, but there isn't. And to reassign the main arrange window start/stop key command to be anything other than the space bar would be a pretty hard thing to become used too, since this command has been in Logic for as long as I can remember.

    Anyone have an idea as to how this conundrum can be resolved? I suppose a request to Apple to add the playback button in the sample editor to the available key commands, but I would really appreciate if this didn't work like this today... editing is a real problem for me, I go between the arrange window and sample editor allow when tweaking vocals...

    Issue # 2... could someone confirm that the flex editor doesn't appear correct when using allot of tempo changes. It seems to me that what I am seeing in the sample editor, and the overview of the audio region in the arrange window, especially if I move a flex marker, is not correct... this is making the whole flex thing a non available function.

    A confirmation of this issue would be great, so I can bring it up to the Apple guys at NAMM in a couple of weeks.

    Thanks people and happy new year, lets hope 2010 is better than 2009 was...

    George Leger III
  3. georgelegeriii

    georgelegeriii Senior member

    Figured out the sample editor solution:

    Logic has a global "Windows showing audio files" key command. Changing both the sample editor "play and stop", as well as the "Windows showing audio files", to option spacebar, solves the problem, and Logic now works as I would expect it too.

    So, if you run into this issue, there is the resolution.

    Hope it helps someone else...

    George Leger III
  4. Eli

    Eli Senior member

    Hi George,

    I TOTALLY agree about the space bar problem when opening the Sample Editor window from the Arrange Window. This really bugs me as well. I haven't really investigated a solution, but will check out the key commands you mention. It sounds like it will cure the problem.

    As far as flex and tempo changes, I'm not really clear on what your specific problem is. Flex markers are created and edited in the Arrange Window. When working in the Sample Edit window, it's about editing the transient markers; which aren't the same as flex markers in the Arrange Window.

    When in the SE window, tempo changes in the Arrange shouldn't be an issue. You just want to verify that the transient markers are exactly on the actual transients in the waveform.

    I haven't specifically experimented with flex markers in the Arrange Window with tempo changes present. But if the waveform isn't being displayed properly here when tempo changes are present, then yeah, this is a serious problem!
  5. Orren Merton

    Orren Merton Logic Samurai / Administrator Staff Member

    As Eli said, the Flex Time display on the Arrange will display based on the bar time in the ruler, but the Transient Editor in the Sample Editor will display the original length of the audio file.

    In other words: let's say you've recorded a 1-minute audio file. When initially recorded at your song's tempo, on the Arrange this region goes from Bar to Bar

    After inserting a lot of tempo changes, now lets say the audio region occurs from Bar to Bar

    When you enable Flex view on the Arrange, it will enable the Flex view on top of the Arrange region, from Bar 1 to Bar 47.

    If you enter the Sample Editor and look at the audio in Transient Edit mode, you will see the full Bar 1 to Bar 60 audio. You can verify this by looking at it in SMPTE mode, the file will be 60 seconds long, even if on the Arrange, after all your tempo changes, it's sped up to 47-seconds.

    Or is it operating differently than this for you?

  6. Jay Asher

    Jay Asher Senior member

    The solution is to make the region a new audio file.

Share This Page