Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Serious Automation Bug Established

Discussion in 'Logic 9' started by HKC, Jun 2, 2013.

  1. HKC

    HKC Senior member

    Hi there

    I posted a thread about a very serious automation but back in January. Due to a tight schedule I haven't been able to go into it until today.
    The problem is in short that automation isn't compensated for on auxes (under certain circumstances). This is of course a huge problem it you ie mute a snare drum and then suddenly it's back again but the following kick is muted instead. It's just an example but pretty much describes the seriousness of the issue.
    It turns out the a few plugins does not compensate when used on an aux (or bus). This if of course with the "all" setting.
    In my relatively large collection it is the PSP Neon HR (only the HR and the STD version, the mix is fine), the Sonnox Supressor HR (the other 2 are fine) and the UAD Precision Multiband (I only the the DeEsser of the rest of the Precision series but that one is fine and so is everything else by Universal that I have).

    The thing in common here could be "HR"....

    If anybody has any of these 3 maybe it would be cool to reproduce it so a fix could be made a little more likely.
    Just set up a small drum pattern with kick on 1-3 and snare on 2-4, route the instrument to an aux or bus, automate the aux/bus so it turns the volume all the way down on 2 and 4, insert any of the 3 plugins, notice how all of a sudden automation is no longer the same place.....

    Hopefully this is reproducible :)

    All the Best
    Henrik
     
  2.  
  3. HKC

    HKC Senior member

    Sorry about my many typing errors but I was in a hurry :)
    Additionally I can tell that it is not enough to bypass the plugins if you want to hear the aux with and without the plugin. You have to take it completely off.
    I have written to Sonnox, Universal and PSP but of course they may reply that it's due to the AU standard and therefore has nothing to do with them.....but I'll give them the benefit of the doubt.
     
  4. CSeye

    CSeye Senior member

    Hello Henrik,

    Assuming I correctly understood your set up description at the bottom of the first post, I'm not seeing a difference.

    First screen shot if of automation before inserting Neon HR, second is with HR.

    I'll have a chance to look at UAD this evening.
     

    Attached Files:

  5. HKC

    HKC Senior member

    It's not the data that moves. It's the sound. You can only hear it, not read it.
    Sorry if I made it sound like the data physically moved. It's the other way around, the latency induced by Neon HR is not compensated for in automation so automation becomes "untight" and takes place before it should. Probably exactly with the latency that Neon HR induces.
     
  6. HKC

    HKC Senior member

    Sorry I have done Sonnox wrong. The Supresser doesn't have the issue. The two others do. To my excuse I went through at least a hundred plugins yesterday.
    Basically it means that you can't use Neon HR or UAD Precision Multiband on an automated aux or bus. The problem with that is of course that both are basically aimed at group masters rather than individual tracks and they are useless there unless you are willing to place you automation by ear and not by eyes.
     
  7. CSeye

    CSeye Senior member

    So with automation on the aux channel, only the kick is heard on the 1 & 3. The snare on the 2 & 4 is not heard.

    Adding Neon HR to the aux channel results in only the snare sounding on 2 & 4. Very weird!!!

    This appears to be a Logic issue as well, as a similar set up in DP 8 with Neon HR on the aux did not result in any automation anomalies.
     
  8. HKC

    HKC Senior member

    Sonnox and Universal have responded and acknowledged the bug. I don't know if it's a Logic bug because it's only these 3 plugins that have the issue.
    I have made a little Logic song that pinpoints the problem. I had a problem explaining exactly what was wrong but now I'm sure that all 3 companies realise that this is a bug, and a very serious one if you use any of the 3 on aux/bus. Ironically two of them are master plugins but cannot be used as such (not under all circumstances that is).

    PS why in the world has nobody else stumbled upon this. I can't even figure out a workaround.
     
  9. CSeye

    CSeye Senior member

    This automation anomaly does not occur in Cubase 7 or DP8.

    With the respective software instrument routed to an aux, with automation on the aux turning the volume completely off on the 2 & 4 so that only the kick is heard on the 1 & 3, there is no problem with the automation in Cubase or DP when inserting either the PSP Neon HR or UAD MB compressor.
     
  10. HKC

    HKC Senior member

    I am not saying it can't be a Logic issue. I'm just saying that all other plugins work fine. Sonnox and Universal are major players so I'm sure that they will get it sorted out if it's an Apple thing. PSP is probably not as powerful but if it's a matter of a Logic update I'm sure it will fix Neon as well.
    Sadly I am not sure if this is high on anybodys list since I'm the first one to have a problem with this strange behaviour......
    Time will tell but it is a bug alright
     

Share This Page